Finding installed Julia version with Juliaup

I’m trying out the juliaup version manager (GitHub - JuliaLang/juliaup: An experimental Julia version manager). One thing I struggle with is seeing which versions are installed. The output

PS C:\Users\DNF> juliaup status
Installed Julia channels (default marked with *):
  *  release

isn’t very informative. What are the actual versions that are installed? For example, today I wanted to update ‘beta’ to 1.7-rc3, but running juliaup update gives me no feedback, and I don’t know what happended. Starting up a Julia instance seems to be the only way to find this out.


  • Can juliaup tell me which versions are installed?
  • Is rc3 currently available via juliaup?

I realize that I am behind on my juliaup version (1.2.6), but I also cannot figure out how to update juliaup itself.


juliaup update still won’t update to RC3, nor does it install 1.6.4. Is this expected?

Agree that the output from juliaup status is not self-explanatory about the versions installed and pinging @davidanthoff should help clarifying.


Before juliaup update had here on Win10’s powershell:

> juliaup status
Installed Julia channels (default marked with *):
     beta (Update from 1.7.0-rc2+0~x64 to 1.7.0-rc3+0~x64 available)
  *  1.6

And after update:

> juliaup update
Installing Julia 1.7.0-rc3+0 (x64).
> juliaup status
Installed Julia channels (default marked with *):
  *  1.6

Then in powershell do:

> juliaup default beta
> julia

Julia REPL then launches and new version was installed:

julia> VERSION

Linking also this post that has more information than I can process.

Thanks for the reply.

There’s definitely something different with my installation, though. I don’t get any info about available updates, and after juliaup update I’m still on 1.7.0-rc2.

Maybe I need to update juliaup itself, but I don’t know how.

Here using: juliaup 1.2.16

To update juliaup you migth need to uninstal old and install new version?
There is this caveat to watch out.

But installing from the Windows store seems a strange experience:

I cannot find “Juliaup” on the windows store. Following the link from the juliaup github points me to Julia, not Juliaup, so it seems that juliaup is bundled with Julia itself in the store?

My head is hurting, and also my tail from biting myself: in order to get Juliaup, a tool for easily updating Julia, I need to install Julia? And in order to update Juliaup, I need to uninstall and reinstall Julia itself?

In Windows store juliaup is named Julia :slight_smile:
It comes with some version of Julia that you will need to update via juliaup in the powershell.

The Julia app name is assigned in your PC (you should uninstall previous Julia instances not installed with the Julia(up) app). When you launch the Julia app from Windows Start menu, you get a REPL using the default Julia version you defined in juliaup. Or just get the REPL by typing julia in the powershell.

NB: for a nice Windows experience, I would recommend using Jeeves.

Thanks for the help. I uninstalled+reinstalled, and that may be the way to go. Unfortunately, due to security policies on my project laptop, I am unable to use Windows Store (I now longer recall how I worked around that last time), so after un-installing Julia, I cannot now reinstall it.

I do wish Juliaup didn’t depend on the Windows Store (which, afaiu, is semi-abandoned by Microsoft), and that there were some builtin way to update it, but perhaps there will be at some point.


Yes, we should add that. Do you want to open an issue over at GitHub - JuliaLang/juliaup: An experimental Julia version manager?

Yes, all official builds should be available.

Yes, I think that is the root problem here. The only “supported” way to use juliaup at the moment is to install Julia itself from the Windows Store. If you do that, you get Julia + a bundled juliaup. The store should then keep everything updated automatically, without any user intervention (that is, juliaup will automatically be kept on the latest version). If you are impatient, you can check for new updates in the Windows Store (the store sometimes doesn’t update instantly but waits a few hours). There is no need to uninstall/reinstall things or anything like that to keep things up-to-date.

So does that mean you originally installed juliaup via some other way than the Windows Store? That is not a supported scenario at the moment.

The Store is very actively maintained by MS, they just released a very large update to it this summer for Windows 11 and now backported that to Windows 10 as well. Plus, the store handles all the self update of juliaup for us. We do need to find a solution for systems that have the Windows Store just plain disabled, but that will take a while to sort out.

1 Like

No, I did install via Windows Store, but this was while the IT department was on the line, disabling and enabling some VPN or firewall settings for some other purpose, and juggling private vs corporate Microsoft accounts. Suddenly it worked, I don’t know how. I cannot install anything from the store now.

OK, I don’t know that much about it, but read about the store having fallen into disrepair, and being largely ignored. Though, I also heard something happening in connection with win 11, so that’s good.