Error using JuliaPro behind corporate firewall

I recently downloaded JuliaPro and started to use the REPL through atom, but I can’t import any packages.

When I try to add anything, I get the following error,

(v1.0) pkg> add JuMP
 Resolving package versions...
ERROR: Error when installing package Calculus:
IOError(MbedTLS error code -9984: X509 - Certificate verification failed, e.g. CRL, CA or signature
check failed during request(

This happens for any package. I’ve tried a handful of things, and oddly enough I can add packages with Julie through the standard terminal, just not atom.

Any suggestions are appreciated - thanks!

I needed to configure git to work through the firewall and then also Atom, if you want to install Atom packages. I’m not at the office, or I could just post my configuration files. Basically, set git to use https and set the proxy server address for both https and http, including the port number. Tell apm not to use strict SSL and set the proxy address.

If you don’t get this to work, let me know and I’ll post my config.

Good luck.

1 Like

Thanks for the advice. I tried some of the things you mentioned already, but not he proxy. I looked for my company’s proxy address but it doesn’t have anything in the LAN settings (it has ‘automatically detect settings’ checked off, no proxy server). It may not be a proxy problem, still not sure.

Is there a configuration script? If so, the proxy address will be in the script.

Any luck with this? I think I might have a similar problem