ENOENT error suddently appearing for both Atom editor and VSCode Julia on a Windows 10 machine

I am facing a very strange problem on one of my Windows 10 64-bit machines with Julia 1.4.0.

The Atom editor with Juno were working fine. Then one day, maybe after a Windows update or installing Slack - couldn’t remember clearly, I tried updating ink and julia-client from command line and had errors.

I tried a clean uninstall of Atom (i.e. after uninstall I also manually deleted the folder holding all plugins). Then after a fresh re-install, when I tried to install any plugin, I got the same problem.

Here’s one example when I tried to install ink:

zpan@EYESWRKSTN3 C:\Users\zpan
# apm install ink
'where git 2>nul' is not recognized as an internal or external command,
operable program or batch file.
'dir /b /s /a:d /od "C:\Users\zpan\AppData\Local\GitHub\PortableGit*" 2>nul' is not recognized as an internal or external command,
operable program or batch file.
Installing ink to C:\Users\zpan\.atom\packages failed

> ink@0.12.3 postinstall C:\Users\zpan\AppData\Local\Temp\apm-install-dir-12039-1312-rymvkd.3quy\node_modules\ink
> node scripts/postinstall.js


npm WARN enoent ENOENT: no such file or directory, open 'C:\Users\zpan\AppData\Local\Temp\apm-install-dir-12039-1312-rymvkd.3quy\package.json'
npm WARN apm-install-dir-12039-1312-rymvkd.3quy No description
npm WARN apm-install-dir-12039-1312-rymvkd.3quy No repository field.
npm WARN apm-install-dir-12039-1312-rymvkd.3quy No README data
npm WARN apm-install-dir-12039-1312-rymvkd.3quy No license field.

npm ERR! file path
npm ERR! path path
npm ERR! code ELIFECYCLE
npm ERR! errno ENOENT
npm ERR! syscall spawn path
npm ERR! ink@0.12.3 postinstall: `node scripts/postinstall.js`
npm ERR! spawn path ENOENT
npm ERR!
npm ERR! Failed at the ink@0.12.3 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\zpan\.atom\.apm\_logs\2020-04-09T11_08_34_748Z-debug.log

I don’t know how to attach the log file here - the file is about 2,500 lines lone so I don’t want to paste it directly here. Therefore, I shared a Google Drive folder that contains this file. Here is the link.

I made sure I am the Administrator and have access to C:\Users\zpan\AppData\Local\Temp. I also looked in that folder and indeed there was no folder named “apm-install-dir-12039-1312-rymvkd.3quy”.

I also removed other language packs and left only English on Windows, as I knew sometimes special characters from other languages could cause issue in paths. However, that had no impact.

At the same time I started having problems with Atom, I also had strange problems with VS Code Julia extension, which seems to be related to not being able to resolve paths. I even saw an error message with the ENOENT error. I posted the details of that problem in the VS Code category.

Because both Atom and VS Code suddenly developed this strange problem with finding paths, I wonder if the root cause is something related to Windows or some application I installed on Windows. However, other apps using web frameworks seem to work fine, e.g. OneNote, Slack. And other PCs with the same Windows updates and same apps installed are working fine, too.

I searched the Internet and found no description of this weird issue. Have spent hours on this because the PC having this problem happens to be my best power horse.

Please help if you have any information or idea. Thanks!!!

After many hours I finally solved this problem.

The cause: for some reason system environmental variable has “ComSpec” set to string “path”, which is totally wrong.

It turns out ComSpec should point to the command line interpreter (see https://en.wikipedia.org/wiki/COMSPEC). But “path” is not a valid path, so this messed with programs that issue commands through the command line interpreter.

After removing the environmental variable, everything returns normal.

I still don’t know how this ComSpec variable was created in the first place.

3 Likes

Good find! Glad it’s working for you know.

Thanks! It certainly was one of the weirdest issues I have met in quite some time.