Documenter fails with ssh error

I’m trying to create my first package (using pkgtemplate) but am running into problems generating the documentation using Documenter. I’ve generated ssh keys using DocumenterTools and have stuck them in the indicated place. But the documentation deployment process spits out the following message. What is going wrong here?

Thanks!!!

Looks like you forgot to given the deploy key write permissions to the repository.

1 Like

This may help:

1 Like

Thank you @fredrikekre and @leandromartinez98 . I regenerated and stuck in the ssh keys in the designated places. Now I get this.

Just to be clear, should these ssh keys go into the Bump.jl repository or in the .io one?

What else could I be missing?

I would recommend clearing the keys you added and follow exactly the steps of the post I mentioned above, and that should do the trick.

Thanks @leandromartinez98 . I followed steps 1-3 (again) and the same problem arises. As for step 4, there currently are no tags. Could that be the problem? What role do those tags play?

@dhairyagandhi96 is apparently seeing the same thing on Flux.jl (example), and has also cycled the keys without success.

Thanks @christopher-dG. @dhairyagandhi96’s problem occurs at the same stage, but appears to be different. Mine is related to the RSA host key; see https://github.com/NittanyLion/Bump.jl/runs/1475194275?check_suite_focus=true .

That RSA key thing isn’t actually an issue, your docs are pushed just fine now. GH Pages sometimes takes a long time to deploy the first version of docs, or your repo settings might be incorrect for GH Pages. Either way you no longer have a Documenter.jl problem. :slightly_smiling_face:

Edit: You did have the “invalid format” error in your first screenshots, and cycling your keys appears to have fixed that.

2 Likes

Thanks @christopher-dG! So how do I get it to show up if one clicks on docs/stable at the bottom of the page?