Documenter stop deploying

Hi,
Since two weeks ago the Documenter stop deploying the docs. It doesn’t tell me why, only Info: skipping docs deployment.
What is wrong here?

Thanks

...
[ Info: SetupBuildDirectory: setting up build directory.
[ Info: ExpandTemplates: expanding markdown templates.
[ Info: CrossReferences: building cross-references.
[ Info: CheckDocument: running document checks.
[ Info: Populate: populating indices.
[ Info: RenderDocument: rendering document.
[ Info: HTMLWriter: rendering HTML pages.
┌ Warning: the `julia` keyword argument to `Documenter.deploydocs` is removed. Use Travis Build Stages for determining from where to deploy instead. See the section about Hosting in the Documenter manual for more details.
│   caller = ip:0x0
└ @ Core :-1
[ Info: skipping docs deployment.

This warning:

See https://github.com/JuliaDocs/Documenter.jl/blob/master/CHANGELOG.md for how to upgrade.

Sorry, update what? If you are referring to hosting instructions I spent hours last night trying to make it work but got nothing but (uncomprehensible to me) errors. To start with the man page is not clear on what to do when the repo is under an organisation instead of individual. And even before that it fails on Windows with

julia> Travis.genkeys(user="joa-quim", repo="git@github.com:GenericMappingTools/GMT.jl.git")
ERROR: IOError: could not spawn `which which`: no such file or directory (ENOENT)
Stacktrace:
 [1] _spawn_primitive(::String, ::Cmd, ::Array{Any,1}) at .\process.jl:400
 [2] setup_stdios(::getfield(Base, Symbol("##505#506")){Cmd}, ::Array{Any,1}) at .\process.jl:413
 [3] success(::Cmd) at .\process.jl:412
 [4] #genkeys#1(::String, ::String, ::Function) at C:\Users\j\.julia\packages\DocumenterTools\QEnZ4\src\Travis.jl:61
 [5] (::getfield(DocumenterTools.Travis, Symbol("#kw##genkeys")))(::NamedTuple{(:user, :repo),Tuple{String,String}}, ::typeof(DocumenterTools.Travis.genkeys)) at .\none:0

I had SSH keys from a previous attempt but as I said, every time I tried to follow one of the advices, type

 Warning: The `assets` keyword argument should now be specified in the
│ `Documenter.HTML()` format specifier. To fix this warning replace
│ ```
│ assets = ...
│ ```
│ with
│ ```
│ format = Documenter.HTML(assets = ...)
│ ```

I fell into a new error.

It’s understandable that you might be quite frustrated by trouble getting this working but sniping at someone who is trying to help you seems like a bad way to get more help.

1 Like

You are right that I am frustrated but I tried to be only factual about the errors and the things I don’t understand, but I don’t have the impression of having been offensive. If I was, I apologies.

Did you see https://juliadocs.github.io/Documenter.jl/stable/man/hosting/#.travis.yml-Configuration-1?

Here is an example: https://github.com/KristofferC/OhMyREPL.jl/blob/9f5e1852f3864e5dc64aaa0fc089e985131e51bc/.travis.yml#L27-L35.

And the corresponding make.jl: https://github.com/KristofferC/OhMyREPL.jl/blob/master/docs/make.jl together with a Project + Manifest in that directory.

Thanks for the pointers, but indeed I had read them all. But as I pointed out in first message, not easy. For example trying to get the keys

julia> Travis.genkeys(user="joa-quim", repo="git@github.com:GenericMappingTools/GMT.jl.git")
ERROR: IOError: could not spawn `which which`: no such file or directory (ENOENT)

Also looked into the examples pointed out in the Docmenter page to realize that many (most) of are them still doing the same thing I used to do until it stop working.

Also had tried what turned out to finally work today, which was to change the deploydocs instruction to

deploydocs(
	repo   = "github.com/GenericMappingTools/GMT.jl.git",
)

but, probably in combination with something else, yesterday I still got incomprehensible errors.

In summary, it now works again though I’m not exactly sure I understand the reason.

If your documentation used to deploy you should already have Travis keys setup so that shouldn’t need to be done again.

The error you are getting seems like an issue with Travis.genkeys in Documenter in that it seems to only work on mac / linux where which is available.

It used to deploy but without the Travis keys (like it’s still not using them now). Another thing I haven’t mention is that when it stop working I actually had it version restricted

julia -e 'using Pkg; ps=Pkg.PackageSpec(name="Documenter", version="0.19"); Pkg.add(ps); Pkg.pin(ps)'

so even more strange that it stop deploying.

Regarding the which, I know that and even have gnu port of it in my Win machine, but if I make it visible then the error changed to

julia> Travis.genkeys(user="joa-quim", repo="git@github.com:GenericMappingTools/GMT.jl.git")
ERROR: 'which' not found.

In the log you linked (https://travis-ci.org/GenericMappingTools/GMT.jl/builds/535090743#L3332) I see

julia -e 'using Pkg; ps=Pkg.PackageSpec(name="Documenter"); Pkg.add(ps); Pkg.pin(ps)'

Where did you set the version= keyword?

Yes, but that link was from after I had removed the version in the first attempts to solve the issue, See this log (probably from the same day, or close)

 julia -e 'using Pkg; ps=Pkg.PackageSpec(name="Documenter", version="0.19"); 

Doing

Documenter: skipping docs deployment.
  You can set DOCUMENTER_DEBUG to "true" in Travis to see more information.

would have been a good idea to see why it didn’t deploy.

It was probably because you had specified that the docs should be deployed from 1.0.3:

but that run was on 1.1.0.

I did that too but couldn’t get any useful info out of it.

Now, that makes sense. Thanks

Yeah but in that log you are not using v0.19 of Documenter anymore so then that advice doesn’t apply.

True. As I said, tried a lot things, but not always in a clairvoyant way.