Difficulty installing packages with JuliaPro

I tried to install your package by " pkg> add “GitHub - oxinabox/ProjectManagement.jl: Project Management tools, with a particular focus on PERT charts”"
but I keep getting this error: “ERROR: failed to clone from https://github.com/JuliaComputing/BinaryProvider.jl.git, error: GitError(Code:ERROR, Class:Net, request failed with status code: 404)”

ANy idea what is going on? I am a Julia newbie. Not sure if I am doing something rather stupid.

try add ProjectManagement

That does not work either unfortunately. But, thanks.

] add https://github.com/oxinabox/ProjectManagement.jl

Should work

] to enter Pkg- mode, then add ProjectManagement
should work.
It’s a registered package.

What error do you get (show us all of it) and what is your Julia version?


My Julia version is 1.5.3. Here is what I get.


This is what happens when I try what you suggested.

Seems like a problem with JuliaPro.
I have asked a moderator to split this thread off into a seperate question about issues installing packages with JuliaPro.
I can’t help you with that unfortunately, as I don’t use JuliaPro.
But hopefully someone else can. :slight_smile:

1 Like

To add to this, is there a specific reason why you are using JuliaPro? If not it might be useful to move to regular Julia, as the vast majority of users on here doesn’t use JuliaPro which makes it harder to get help with JuliaPro-specific issues

1 Like

That is because I am a complete newbie. What do people use in general for Julia if they are using Windows?

“In general” is hard to say, but I’d think the most common setup is the normal Julia version (either 1.5.4 or 1.6.0rc3, the release candidate of soon-to-be released 1.6) together with either Juno/Atom or VSCode as an IDE, or IJulia/Jupyter notebooks or Pluto for notebooks.

That said there’s support for loads of different setups, and I know of people using Sublime Text, Vim, Emacs, and many other solutions successfully - if you have a preferred setup from some other language it’s likely that some sort of Julia support for it exists.


Thank you all. I uninstalled JuliaPro and installed Atom/Juno. I then
Pkg>add ProjectManagement,
which worked. However, when I tried to use it in a script. Here is what I got:

Then also bunch of other errors. ANy ideas? Here is another error below this:

Can you try deleting the .julia folder and trying again?

Would you like to use a bundled VS Code with Julia? All preconfigured and ready to go. Portable Julia - #9 by PetrKryslUCSD

Sorry, introduced a bug by a premature push. Update has just been uploaded. Feel free to use that.

Please execute following command to fix this issue on JuliaPro

using Pkg

Thank you! I will check it out.

Is it OK to remove a registry? Will it mess up with other things?

Is it OK to remove a registry? Will it mess up with other things?

Yes, it should be OK to remove “JuliaPro” registry and it should not mess up your installation. Based on your logs, your JuliaPro installation had 3 registries


Packages will be pulled from JuliaComputingRegistry and General registries once JuliaPro registry is removed.


What you said + “] build GR” solved my problem. Thanks!