Cannot install any package on JuliaPro 0.6.2.2


#1

Hello everyone,

I need some help.
I’m on windows 8 and I just installed JuliaPro 0.6.2.2
I cannot install any package. For now I only tried with YAML, Plots and Cubature and none of them work.

They all give the same error:

julia> Pkg.add("Cubature")
INFO: Cloning cache of Cubature from https://github.com/stevengj/Cubature.jl.git
ERROR: Cannot clone Cubature from https://github.com/stevengj/Cubature.jl.git. user cancelled certif
icate check:
prefetch(::String, ::String, ::Array{String,1}) at .\pkg\cache.jl:56
resolve(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.Pkg.Types.Av
ailable}}, ::Dict{String,Tuple{VersionNumber,Bool}}, ::Dict{String,Base.Pkg.Types.Fixed}, ::Dict{Str
ing,VersionNumber}, ::Set{String}) at .\pkg\entry.jl:516
resolve(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.Pkg.Types.Av
ailable}}, ::Dict{String,Tuple{VersionNumber,Bool}}, ::Dict{String,Base.Pkg.Types.Fixed}) at .\pkg\e
ntry.jl:479
edit(::Function, ::String, ::Base.Pkg.Types.VersionSet, ::Vararg{Base.Pkg.Types.VersionSet,N} where
N) at .\pkg\entry.jl:30
(::Base.Pkg.Entry.##1#3{String,Base.Pkg.Types.VersionSet})() at .\task.jl:335

The error looks similar to the one discribed in this topic except that in my case it’s not Plots specefic.

Many thanks in advance


#2

Sorry,
I realized this must be a duplicate of Git / Pkg Error.


#3

Or you can simply link to the Git error post and leave this thread as a reference to other people.