Debugging in VS Code suddenly stopped working

Hi everyone, I’m having some trouble debugging my julia code in VS Code and it’s getting me out of my mind. It possibly is because I don’t understand quite exactly how debugging works (I’ve searched for it but didn’t get much progress in the last hours), so I decided to ask you for help.

I have been using VS Code for a while, and the past week I have been working intensely in a julia code. Running it, debugging it, changing it, etc. The thing is, yesterday, out of a sudden, the debug button (little play symbol with a bug on it) started doing nothing. It has been very stressful hours, because I was being super productive for once, so I’ll list what I have tried so far, without success:

  • Debugging using F5;
  • Closing the file, the folder, VS Code itself, reopening it and trying again;
  • Uninstalling and reinstalling the julia extension;
  • Uninstalling and reinstalling VS Code;
  • Uninstalling and reinstalling Julia;

All of the above while using Linux Mint. After all that I decided to restart my computer and initialize it with Windows 10. I performed everything listed above again, without success.

I then searched the forum and found there was a way to debug I didn’t know of: I typed Ctrl + Shift + P and searched for Julia: Debug File in New Process, which didn’t work any of the times I tried it, but at least gave me an error message:

julia

I must say that the code runs normally when pressing the play button on the top right of the window or starting through the terminal, but nothing happens when using Ctrl + F5.

Can anyone give me some light as to what is happening and/or what I can do to fix it? I really need to debug this code, and I really wish to not having to change IDE because of this.

I appreciate any type of answer, thanks!

NO Solution for you Unfortunately - confirming that the same thing happened to me a few days ago on a pure Win10 system. This happened in the past to me with the Python language also. Reinstalling sometimes worked and never found a “proper sequence of things to follow to get it to work again” – I can’t get the Julia stuff to work anymore even after reinstalling, reinstalling and deleting all VScode files…

Hitting a deadline for my Julia code I now decided to switch to JuliaPro; installed it and debugging code as before. Hurts because all my coding on Python, MicroPython, ARM you name it I do on VSCode but if I can’t rely on it for my commercial projects … time to go…

1 Like

Looks like a recent minor or patch update is to blame: "Start debugging" does not work anymore in 1.1.33 / Ubuntu · Issue #2004 · julia-vscode/julia-vscode · GitHub.

As the issue notes, you can still invoke the debugger from the REPL. I’d also have a look at the extension output to see if it’s logging or throwing anything fishy.

1 Like

Thanks for the links! As the author o the issue noted, installing a previous version of the extension works. I did it and now things are back to normal. :wink:

1 Like

That bug is fixed with 1.1.34, so updating should be safe. Sorry for the inconvenience.