Could not start Julia Server VSCode in WSL2

I installed Julia 1.8.1 using WSL2 as explained here and added it to my PATH

After that I’ve installed Julia Extension and created a new project I got error message `Could not start the Julia Language Server’.


If I click the open settings it doesn’t find the julia.executablePath setting, nonetheless after adding the path to that specific setting, also added to julia.environmentPath, in the settings.json nothing has happened. (my in WSL path is ~/julia-1.8.1/bin/julia)

Does anyone have an idea of what could be happening?

Possibly try using the fully qualified path, instead of ~ for home, that may help?

1 Like

Are you using the remote extension for WSL? I don’t think this is expected to work without that.

1 Like

Yes, I’m using it

Yeah, that actually made it work. Now I can start a REPL and run code as usual, but for some reason Julia extension is not showing up in the sidebar.

It may be hidden, if you right click on the side bar there may be an option. Otherwise:

In the command palette (Ctrl+Shift+P) ^^

1 Like