Compat Issues Messing Me Up - Help needed

Hi everyone,

I’m trying to keep my package a float(https://github.com/caseykneale/ChemometricsTools.jl)… It was working fine then DSP.jl broke due to issues with FFTW? This happened 2 releases ago v0.5.8.

So I removed DSP.jl and tried to update my [compat]. Now despite my best efforts, https://github.com/caseykneale/ChemometricsTools.jl/blob/master/Project.toml
I tried to install my package, and it was throwing errors about julia downversioning or something on a different computer. So it preferentially installed 0.5.8 which is of course completely broken.

How do I get out of this broken compatibility loop? Is there a way to “fix” an old release?

The DSP/FFTW issue has been resolved, so if you can use the latest DSP.jl (0.6.1) it should be OK.

FWIW I just installed your package into a fresh environment (both the released version and master) and it seemed to install fine, so maybe there’s some other package you have installed that’s causing problems?

2 Likes

Maybe it was Julia 1.05 that was busted?

I think the issue is 0.5.8’s compat line specifies a specific version of DSP or is capped to the version that is busted? So if 0.5.9 fails to install a user gets redirected to 0.5.8 which is broken (I think) due to DSP. Not sure. Maybe that computers environment just needs burned down.