Upgrade to lower numbered package

When I update in Pkg it actually downgrades quite a lot of packages.
My best guess was that this was happening as a result of some package that depend on old packages.
But when I got a new version of julia, updated and then only installed StochasticIntegrals with:

(@v1.6) pkg> add StochasticIntegrals

It installed the old version (v2.1). So it seems like my computer just likes old package versions. Any idea what could be causing this and how to fix it?

Below shows a larger number of downgrades when I upgraded in the REPL.

(@v1.6) pkg> update
Updating registry at C:\Users\dr\.julia\registries\General
Updating git-repo https://github.com/JuliaRegistries/General.git
Installed GeometryBasics ────── v0.3.12
Installed StructArrays ──────── v0.5.1
Installed ColorTypes ────────── v0.10.12
Installed StochasticIntegrals ─ v0.2.1
Installed StaticArrays ──────── v0.12.5
Installed Distributions ─────── v0.23.12
Installed DataFrames ────────── v1.2.2
Installed PrettyTables ──────── v1.1.0
Updating C:\Users\dr\.julia\environments\v1.6\Project.toml
[c52e3926] ↑ Atom v0.12.10 β‡’ v0.12.34
[a93c6f00] ↑ DataFrames v0.22.7 β‡’ v1.2.2
[31c24e10] ↓ Distributions v0.25.11 β‡’ v0.23.12
[b15139f2] ↓ StochasticIntegrals v0.4.2 β‡’ v0.2.1
Updating C:\Users\dr\.julia\environments\v1.6\Manifest.toml
[a4c015fc] - ANSIColoredPrinters v0.0.1
[c52e3926] ↑ Atom v0.12.10 β‡’ v0.12.34
[7057c7e9] - Cassette v0.3.8
[324d7699] - CategoricalArrays v0.9.7
[d360d2e6] - ChainRulesCore v1.3.0
[da1fd8a2] ↑ CodeTracking v0.5.12 β‡’ v1.0.6
[3da002f7] ↓ ColorTypes v0.11.0 β‡’ v0.10.12
[a80b9123] + CommonMark v0.8.2
[a93c6f00] ↑ DataFrames v0.22.7 β‡’ v1.2.2
[31c24e10] ↓ Distributions v0.25.11 β‡’ v0.23.12
[e30172f5] ↓ Documenter v0.27.5 β‡’ v0.26.3
[1a297f60] ↓ FillArrays v0.12.2 β‡’ v0.9.7
[817d07cb] - FixedPointAcceleration v0.3.2
[fb4132e2] + FuzzyCompletions v0.4.3
[5c1252a2] ↓ GeometryBasics v0.3.13 β‡’ v0.3.12
[b5f81e59] ↓ IOCapture v0.2.2 β‡’ v0.1.1
[98e50ef6] ↑ JuliaFormatter v0.3.7 β‡’ v0.13.7
[aa1ae85d] ↑ JuliaInterpreter v0.7.26 β‡’ v0.8.21
[e1d29d7a] ↑ Missings v0.4.5 β‡’ v1.0.1
[54e48022] + MultivariateFunctions v0.1.0
[90014a1f] ↓ PDMats v0.11.1 β‡’ v0.10.1
[08abe8d2] ↑ PrettyTables v0.11.1 β‡’ v1.1.0
[a2af1166] ↑ SortingAlgorithms v0.3.1 β‡’ v1.0.1
[276daf66] ↓ SpecialFunctions v1.6.1 β‡’ v0.10.3
[90137ffa] ↓ StaticArrays v1.2.12 β‡’ v0.12.5
[b15139f2] ↓ StochasticIntegrals v0.4.2 β‡’ v0.2.1
[09ab397b] ↓ StructArrays v0.6.0 β‡’ v0.5.1
[856f2bd8] - StructTypes v1.7.2
[37b6cedf] - Traceur v0.3.1
[5c2747f8] + URIs v1.3.0
Precompiling project…

1 Like

Ah good point. So due to DataFrames being at 1.2.2 now it goes back to a previous version of StochasticIntegrals that does not have an upper bound compat entry.

this is your master branch. DataFrame has long been 1.0 now It’s hard to say what caused what when you have so big out dated dependencies. Distributions is 0.25.x now

Yeah. As I understand compat should be the oldest version that works with your code. So I did not change from the versions that were current when I wrote it (so start of range is old DataFrame and old Distributions). I guess that I got the upperbound wrong for DataFrames when I had to do a compat entry for the registry.

yes, but your upper bound for DataFrames is 0.x?.. you can do

= "^0.20, ^1.0"

maybe

Yep. that is what I was trying to do. I will change That. Thanks.