Can't Authenticate on Firefox to manage packages

Hi, after a few months of inactivity, starting up again on a Julia program, I tried to add a new package, and was unable to authenticate on Firefox (or Microsoft Explorer either).
The webpage did pop up as usual, but the authentication button vanished immediately, and was replaced with the message, “Firefox Can’t Open This Page”. There was nowhere to click to authenticate, and in fact the webpage kept popping up uncontrollably with very many new tabs, all with the same error message. Has the authentication process changed? Can I fix it?

(My current version of Julia seems to be Julia 1.4.2-1. I would very much like to NOT have to update to a new version of Julia right now.)

For example:

   Updating registry at `C:\Users\MyName\.juliapro\JuliaPro_v1.4.2-1\registries\JuliaPro...`
│    Could not download https://pkg.juliacomputing.com/auth/renew/token.toml/v2/ to C:\Users...
Authentication required: please authenticate in browser.
The authentication page should open in your browser automatically, but you may need to switch to the opened window or tab. If the authentication page is not automatically
opened, you can authenticate by manually opening the following URL: https://pkg.juliacomputing.com/auth/response?3d9acfd669a78ec87eca65d899c114df```

It’s there a particular reason why you’re using JuliaPro? There’s not been any development of JuliaPro since version 1.5 I believe, and you’re unlikely to get help with JuliaPro errors as pretty much no one on here is using it.

I’d strongly recommend you update to the latest stable version (1.7.3), or if you’re very averse to updating Julia at least the latest LTS version, which is 1.6.6.

If you feel strongly about using an outdated version of JuliaPro, you should be able to get around the error you’re seeing by removing the JuliaComputing registry and just using the General registry instead.

1 Like

Yes, usage of JuliaPro is very much discouraged these days.

1 Like

Hi, I am reticent to leave JuliaPro, because when I first installed Julia, I had massive errors that were never solved (even by the creators of Julia), until I finally installed with JuliaPro. Also, re-installing things sounds like I have to re-install all of the packages, which could plunge me back into package management chaos. (It seems that some packages conflict with other packages, but only if you install A before B, not B before A, and so on.)

Anyway… could you please give me simple step-by-step instructions on how to least destructively update my ecosystem out of JuliaPro?

And, as a fallback, when you say “removing the JuliaComputing registry and just using the General registry instead”, could you detail what that means also?

(Though I’d rather update to a maintained version, if possible.) Thanks!

I’d say the best way forward for a former JuliaPro user is:

  • Install Julia 1.7.3
  • install VSCode
  • install the Julia plug in for VSCode

There’s no need to reinstall packages, you can just instantiate any existing projects you have from their Project.toml files. If you’ve got packages in your default environment you can also just copy that over to the 1.7 directory.

1.7 is three minor releases on from 1.4.2 so in principle everything should “just work”. There might however have been breaking changes to some packages you are using so it’s worth comparing version numbers after you’ve instantiated your environments on 1.7 to see which packages were upgraded.

Sorry and for the fallback: just do

] registry rm JuliaComputingRegistry

you should have the General registry installed already (as far as I can recall it was preinstalled for JuliaPro as well), so once you’ve removed the Julia Computing registry a simple up should work. If it doesn’t you can then do

] registry add General

to add the “normal” general registry.