Issues with PKG (Authentication Procedure) with Julia Pro 1.4.0-1 on Windows 10

I installed the current latest version of JulaiPro - 1.4.0-1 on my Windows machine.
I’m having some issues with the PKG manager.

When I try to add a package this is what I get:

The broswe opens and I log on onto my Julia Computing account.
I go back and click enter. Then the Browser window pops again. Tried few times and it seems not to work.

I also tried the manual way. I went to and downloaded my auth.toml file. I put it in the path written above. Restarted Julia and Juno yet with the same result.
Some issue with the authentication to the registry.

Could anyone assist me to solve this?
Is this some kind of a bug?

Thank You.

Yes, this is a bug (which I didn’t have any luck reproducing). Do you have a restrictive firewall set up or is there another reason why HTTP requests might be blocked?

I’d also be happy to take this to slack for more synchronous communication if you want.

@pfitzseb, Nothing beyond Windows 10 default.

I’m available on Slack, I’d be happy to try give more info.

The strange thing is, why does it ignore the local auth.toml and even after I put it in place it triggers the on demand authentication?

Working on this with @pfitzseb we figured out 2 things:

  1. When trying to put the file manually one should pay attention that the filename from the download from Julia computing has the name token.toml while the name in the folder should be auth.toml. I think it is better the download will have the correct name to begin with. For now pay attention and manually rename the file. Once you do, it will work.

    Pay attention that the renaming is implicitly asked in the REPL for those who paid attention and saw the downloaded file had a different name.

  2. We couldn’t reproduce the issues of repeating errors in the automated authentication.

@pfitzseb, Thank you for the effective support.