Cannot install IJulia 0.6.1 on Windows 8.1, blocked at "downloading miniconda installer"


#1

Hello,

I’m new to Julia so hopefully this is an appropriate place to ask this question.

I’m trying to install IJulia following the recommended way: Pkg.add("IJulia").
It works until getting stuck on downloading miniconda installer ...
I waited 15 mins and nothing happened, no CPU activity anymore etc.
So I shut the Julia window down.

The thing is I already have Anaconda installed, since I used Python a bit with Spyder already. Never ran Jupyter though (this may have some importance later).
So I suspect there could be a problem with my Anaconda (not sure about the link between Anaconda and Miniconda but there must be one).
I Googled and found a few similar isssues on their Github but not the same exact one.
This mostly involves setting the Jupyter path in Windows, and trying to install IJulia the other recommended way.

So I tried one of these ways that seemed like it could work since it solved other similar problems:

ENV[“JUPYTER”]= "C:\\Users\\myusername\\Anaconda3\\Scripts"
Pkg.build(“IJulia”)

This path is where my jupyter.exe is located (even though when I typed where jupyter in Windows, it doesn’t find it btw, nor where python if that matters…).

But in the end, this gives the exact same problem.

I’m really lost and not sure what to do…
I’ll take any advice because there’s this IJulia package I really want to try, so thanks in advance! :slight_smile: