Problem using IJulia

jupyter

#1

I keep getting this error when I try running Pkg.build(“IJulia”). I’ve already tried uninstalling and reinstalling Julia - both 0.5.0 and 0.5.1 - (including deleting the Julia folder), using Pkg.checkout(“IJulia”), and installing Jupyter separately beforehand (using the Anaconda package) and linking the path.

I’ve also subsequently tried installing both Anaconda & Miniconda as admin, and setting the path. I got pretty much the same error in both cases when I tried to run Pkg.build(“IJulia”). The error message said it was too old, got a 0.0.0 when it required >3.0 & tried to install Jupyter using the Conda package.

I’m not sure why this is the case, since I downloaded the latest installer for both Anaconda & Miniconda. I’m also not sure if I’m setting the ENV[“JUPYTER”]path correctly.Should I be setting the path to anything more specific?

Any help on this would be greatly appreciated!


#2

This should be the path to the jupyter executable file. You are using "/C:/Miniconda3", which seems like it is not a valid Windows path to begin with, and any any case it looks like you are trying to type the path of a directory and not of an executable.

In general, I would recommend just not setting JUPYTER at all, and letting IJulia install its own Miniconda distribution, as this is a lot easier. You can also try Julia Pro, which bundles all of this stuff for you.


#3

May be co?

ENV[“JUPYTER”] = “C:\\Miniconda3\\Scripts\\jupyter.exe”