Can I get the REPL in Juno (or anywhere in Windows) to show Unicode above U+010000?

If I use the bold face characters (as used in Unitful and entered with \bfM) such as

julia> c
'�': Unicode U+01d40c (category Lu: Letter, uppercase)

they display correctly in the Workspace window
but do not display correctly in the REPL, either in Juno or in a command shell.

I don’t think it is a font issue because it is displayed correctly in the Workspace (although it’s also not displaying here in my browser even in the preview pane, instead giving me a question-mark-in-diamond.

Some googling suggests that Windows console doesn’t support Unicode above the BMP (Basic Multilingual Plane) meaning it only supports characters from 0x0000 up to 0x10000.

Is there a workaround (aside from installing Linux, virtually installing Linux, etc.)?

I feel like it is a font issue. � is the “unknown” or unrepresentable character. Did you change the font used by the editor? Or are you using the default?

The issue is that the Windows console does not support fallback fonts. See e.g. \mscr unicode character display in REPL with Windows

Workaround: use a different terminal. Either mintty or the new Windows Terminal or …


Thanks for that link - I can confirm that julia, run directly from git-bash under Windows does display those characters correctly (as does my phone under Termux!), but if I launch Atom from bash (tried several different ways), it still doesn’t display them correctly in the REPL window.