Atom compatibility problem when installing julia packages

#1

I’m trying to install a package in julia and get the following error message (this has happened with a couple of packages), which mentions a compatibility issue with Atom. Any ideas?

(v1.1) pkg> add KernelDensity.jl
  Updating registry at `C:\Users\uctpdtz\.julia\registries\General`
  Updating git-repo `https://github.com/JuliaRegistries/General.git`
 Resolving package versions...
ERROR: Unsatisfiable requirements detected for package DebuggerFramework [67417a49]:
 DebuggerFramework [67417a49] log:
 ├─possible versions are: 0.1.0-0.1.2 or uninstalled
 ├─restricted by compatibility requirements with Atom [c52e3926] to versions: 0.1.0-0.1.2
 │ └─Atom [c52e3926] log:
 │   ├─possible versions are: [0.1.0-0.1.1, 0.2.0-0.2.1, 0.3.0, 0.4.0-0.4.6, 0.5.0-0.5.10, 0.6.0-0.6.17, 0.7.0-0.7.15, 0.8.0-0.8.2] or uninstalled
 │   └─restricted to versions 0.7.14 by an explicit requirement, leaving only versions 0.7.14
 └─restricted by julia compatibility requirements to versions: uninstalled — no versions left
2 Likes

Julia does not start in Atom anymore (?)
#2

Try

rm -m DebuggerFramework

(in the Pkg REPL) as suggested here. I had the same problem and it worked for me.

3 Likes

#3

Thanks, that worked.

0 Likes

#4

Update: it worked but then when I relaunched atom it now crashed because, I think, I had deleted Debugger. I then reinstalled julia and juno and all packages worked fine.

0 Likes

#5

Thanks aalexandersson! I had the same problem and this solved it.
How do you find this?

0 Likes

#6

Had the same error rm -m DebuggerFramework didn’t work for me. But after I upgraded Julia from 1.01 to 1.1 everything started working fine.

0 Likes