[ANN] Juno 0.6.7

announcement
juno

#6

Not yet, but a new version of JuliaPro will include this soon.


#7

After I upgrade the julia packages and update the ink, julia-client, language-julia packages. My atom can’t open any files, any windows except for the blank windows, even after I do atom --clear-window-state. I can open things like julia console… My atom works after I disable the julia packages.

I use mac high sierra, julia 0.6.2 and atom 1.23.3.


#8

HI,

I have Julia 0.6.2, Atom 1.23.3 on OSX and uber-juno 0.1.2. I keep seeing things like
WARNING: Atom.jl: unrecognised message validatepath.

Did I make a mistake?


#9

I had some issues with the installation (I had to install manually all the Atom packages, they didn’t installed with uber-juno automatically) but after that is works great, the new REPL is nice.

A small issue I ran into is that it seems there’s no way to close the doc that show in your code (Ctrl+j Ctrl-d). It would maybe be better to show it in the doc pane.


#10

No, but


#11

The installation problems are strange – I can’t reproduce them.

A small issue I ran into is that it seems there’s no way to close the doc that show in your code (Ctrl+j Ctrl-d). It would maybe be better to show it in the doc pane.

You can use Esc to hide the inline docs. And to be honest I rather like having both inline documentation and the doc pane – feel free to open an issue at the Juno.jl repo if you want to discuss though :slight_smile:


If you want to help debug this, please re-enable julia-client and ink, restart Atom, and open the dev console with Cmd-Shift-I (or got to View > Developer > Toggle Developer Tools). There will most likely be some error messages there; open a new issue and paste them there.


Atom.jl: unrecognised message changemodule, validatepath
#12

@Non-Contradiction That error should be fixed with ink 0.8.1, so you should be good to go after an update.


#13

After updating, the Console Style was set to the new REPL-based mode in the julia-client and I had to disable the Enable Powershell Wrapper option manually in order to have a functioning Juno. (Error in the Developer Tools Console: "Uncaught (in promise) Couldn’t resolve path.)


#14

Just wanna say keep up the good work guys, its an absolute pleasure to work in Juno!

Also, if anyone’s not checked it out yet, I highly recommend trying out the profiling feature in Juno, its a bit underadvertised but insanely slick!


#15

I seem to have issues with the help mode, the error below persists after restarting Juno and on two different computers. The error does not occur in a REPL in the regular terminal

help?> sin
search:ERROR: ArgumentError: abstract type is not a valid key for type Symbol
Stacktrace:
 [1] setindex!(::Dict{Symbol,Void}, ::Void, ::String) at ./dict.jl:414
 [2] push! at ./set.jl:35 [inlined]
 [3] unique_from(::Array{Any,1}, ::Array{Symbol,1}, ::Set{Symbol}, ::Int64) at ./set.jl:157
 [4] unique(::Array{Any,1}) at ./set.jl:140
 [5] accessible(::Module) at ./docs/utils.jl:362
 [6] completions at ./docs/utils.jl:367 [inlined]
 [7] repl_search(::Base.TTY, ::String) at ./docs/utils.jl:124

#16

If your path to Julia has spaces in it this should be fixed with the next release of julia-client.

Huh… interesting. I’m pretty sure this isn’t Juno’s fault and can’t reproduce on any machine I have available.


#17

How does one get the terminal inside Juno as in the picture (of the post)?


#18

Julia Client: Open Console (or Ctrl-J Ctrl-O) and Julia Client: New Terminal respectively.


#19

First open the Command Palette from the Packages menu or (Ctrl+Shift+P), then do Julia Client: Open Console (or Ctrl-J Ctrl-O) and Julia Client: New Terminal, respectively as @pfitzseb said.


#20

In stacktraces in the REPL, links on lines that are broken (linebreak) are not clickable.


#21

Yes, that’s an upstream issue.


#22

Just to clarify, upstream as in Julia Base, or Atom?


#23

Neither :slight_smile: Upstream as in xterm.js: https://github.com/xtermjs/xterm.js/issues/24


#24

When I do Julia Client: I see Open Console (or Ctrl-J Ctrl-O) and Open A Repl (or Ctrl-j Ctrl-R).

However, Open Console does not invoke the console for me but opens the Repl. I can not open the console anymore. Is that behaviour intentional?


#25

If you want to get the old Console back you’ll need to go to Settings > julia-client > Console Style and select “Legacy” there. That style is deprecated though and won’t be officially supported in the future.