ADD IJulia installation: Julia 1.1 failed, 1.0.3 works

question
#1

I tried adding Blosc and ZMQ manually (both “works meaning error-free”) but same error as below:

_
_ _ ( )_ | Documentation: https://docs.julialang.org
( ) | ( ) ( ) |
_ _ | | __ _ | Type “?” for help, “]?” for Pkg help.
| | | | | | |/ ` | |
| | |
| | | | (
| | | Version 1.1.0 (2019-01-21)
/ |_| | |_ '_| | Official https://julialang.org/ release
|__/ |

(v1.1) pkg> add IJulia
Updating registry at C:\Users\John\.julia\registries\General
Updating git-repo https://github.com/JuliaRegistries/General.git
Resolving package versions…
Updating C:\Users\John\.julia\environments\v1.1\Project.toml
[no changes]
Updating C:\Users\John\.julia\environments\v1.1\Manifest.toml
[no changes]

julia> using IJulia
[ Info: Precompiling IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a]
ERROR: LoadError: Blosc not installed properly, run Pkg.build(“ZMQ”), restart Julia and try again
Stacktrace:
[1] error(::String) at .\error.jl:33
[2] top-level scope at C:\Users\John.julia\packages\ZMQ\ABGOx\src\ZMQ.jl:14
[3] include at .\boot.jl:326 [inlined]
[4] include_relative(::Module, ::String) at .\loading.jl:1038
[5] include(::Module, ::String) at .\sysimg.jl:29
[6] top-level scope at none:2
[7] eval at .\boot.jl:328 [inlined]
[8] eval(::Expr) at .\client.jl:404
[9] top-level scope at .\none:3
in expression starting at C:\Users\John.julia\packages\ZMQ\ABGOx\src\ZMQ.jl:13
ERROR: LoadError: Failed to precompile ZMQ [c2297ded-f4af-51ae-bb23-16f91089e4e1] to C:\Users\John.julia\compiled\v1.1\ZMQ\CaaO6.ji.
Stacktrace:
[1] error(::String) at .\error.jl:33
[2] compilecache(::Base.PkgId, ::String) at .\loading.jl:1197
[3] _require(::Base.PkgId) at .\loading.jl:960
[4] require(::Base.PkgId) at .\loading.jl:858
[5] require(::Module, ::Symbol) at .\loading.jl:853
[6] include at .\boot.jl:326 [inlined]
[7] include_relative(::Module, ::String) at .\loading.jl:1038
[8] include(::Module, ::String) at .\sysimg.jl:29
[9] top-level scope at none:2
[10] eval at .\boot.jl:328 [inlined]
[11] eval(::Expr) at .\client.jl:404
[12] top-level scope at .\none:3
in expression starting at C:\Users\John.julia\packages\IJulia\fjEtl\src\IJulia.jl:36
ERROR: Failed to precompile IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a] to C:\Users\John.julia\compiled\v1.1\IJulia\nfu7T.ji.
Stacktrace:
[1] error(::String) at .\error.jl:33
[2] compilecache(::Base.PkgId, ::String) at .\loading.jl:1197
[3] _require(::Base.PkgId) at .\loading.jl:960
[4] require(::Base.PkgId) at .\loading.jl:858
[5] require(::Module, ::Symbol) at .\loading.jl:853

julia>

0 Likes

#2

Perhaps install it then.

0 Likes

#3

Also, please quote your code (you can edit your post):

1 Like

#4

As shown below, upon adding Blosc, it apparently stops & drops into ZSH showing the name of my PC followed by a “#” sign
If I do it again after exiting ZSH, it would “work meaning no error”
and “add IJulia” again shows no error,
however “using IJulia” would end up with the same error of “Blosc not installed properly…”

| | || | | | (| | | Version 1.1.0 (2019-01-21)
/ |_|||_’_| | Official https://julialang.org/ release
|__/ |

(v1.1) pkg> add Blosc
Updating registry at C:\Users\John\.julia\registries\General
Updating git-repo https://github.com/JuliaRegistries/General.git
Resolving package versions…
Installed MbedTLS Ä v0.6.7
Updating C:\Users\John\.julia\environments\v1.1\Project.toml
[no changes]
Updating C:\Users\John\.julia\environments\v1.1\Manifest.toml
[739be429] MbedTLS v0.6.6 ? v0.6.7
Building MbedTLS C:\Users\John\.julia\packages\MbedTLS\XkQiX\deps\build.log
ZEN8# eexit

(v1.1) pkg> add Blosc
Resolving package versions…
Updating C:\Users\John\.julia\environments\v1.1\Project.toml
[no changes]
Updating C:\Users\John\.julia\environments\v1.1\Manifest.toml
[no changes]

(v1.1) pkg> add IJulia
Resolving package versions…
Updating C:\Users\John\.julia\environments\v1.1\Project.toml
[no changes]
Updating C:\Users\John\.julia\environments\v1.1\Manifest.toml
[no changes]

julia> using IJulia
[ Info: Precompiling IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a]
ERROR: LoadError: Blosc not installed properly, run Pkg.build(“ZMQ”), restart Julia and try again
Stacktrace:
[1] error(::String) at .\error.jl:33
[2] top-level scope at C:\Users\John.julia\packages\ZMQ\ABGOx\src\ZMQ.jl:14
[3] include at .\boot.jl:326 [inlined]
[4] include_relative(::Module, ::String) at .\loading.jl:1038
[5] include(::Module, ::String) at .\sysimg.jl:29
[6] top-level scope at none:2
[7] eval at .\boot.jl:328 [inlined]
[8] eval(::Expr) at .\client.jl:404
[9] top-level scope at .\none:3
in expression starting at C:\Users\John.julia\packages\ZMQ\ABGOx\src\ZMQ.jl:13
ERROR: LoadError: Failed to precompile ZMQ [c2297ded-f4af-51ae-bb23-16f91089e4e1] to C:\Users\John.julia\compiled\v1.1\ZMQ\CaaO6.ji.
Stacktrace:
[1] error(::String) at .\error.jl:33
[2] compilecache(::Base.PkgId, ::String) at .\loading.jl:1197
[3] _require(::Base.PkgId) at .\loading.jl:960
[4] require(::Base.PkgId) at .\loading.jl:858
[5] require(::Module, ::Symbol) at .\loading.jl:853
[6] include at .\boot.jl:326 [inlined]
[7] include_relative(::Module, ::String) at .\loading.jl:1038
[8] include(::Module, ::String) at .\sysimg.jl:29
[9] top-level scope at none:2
[10] eval at .\boot.jl:328 [inlined]
[11] eval(::Expr) at .\client.jl:404
[12] top-level scope at .\none:3
in expression starting at C:\Users\John.julia\packages\IJulia\fjEtl\src\IJulia.jl:36
ERROR: Failed to precompile IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a] to C:\Users\John.julia\compiled\v1.1\IJulia\nfu7T.ji.
Stacktrace:
[1] error(::String) at .\error.jl:33
[2] compilecache(::Base.PkgId, ::String) at .\loading.jl:1197
[3] _require(::Base.PkgId) at .\loading.jl:960
[4] require(::Base.PkgId) at .\loading.jl:858
[5] require(::Module, ::Symbol) at .\loading.jl:853

0 Likes

#5

the build log may contain information about the error:

0 Likes

#6

This is content of the log file below:

â"O Warning: platform_key() is deprecated, use platform_key_abi() from now on
â", caller = ip:0x0
â"" @ Core :-1
[ Info: Downloading https://github.com/JuliaWeb/MbedTLSBuilder/releases/download/v0.17.0/MbedTLS.v2.16.0.x86_64-w64-mingw32.tar.gz to C:\Users\John.j
ulia\packages\MbedTLS\XkQiX\deps\usr\downloads\MbedTLS.v2.16.0.x86_64-w64-mingw32.tar.gz…
[ Info: using prebuilt binaries

0 Likes

#7

I started from scratch (uninstall 1.1 then re-download v1.1 Julia then install), below is relevant screen capture & log files
Please advise
------------------------------------ console
[4ec0a83e] + Unicode
Building Conda ÄÄ C:\Users\John\.julia\packages\Conda\CpuvI\deps\build.log
Building ZMQ ÄÄÄÄ C:\Users\John\.julia\packages\ZMQ\ABGOx\deps\build.log
ZEN8# eexit
Building MbedTLS ? C:\Users\John\.julia\packages\MbedTLS\XkQiX\deps\build.log
ZEN8# eexit
Building IJulia -? C:\Users\John\.julia\packages\IJulia\fjEtl\deps\build.log
------------------------------------ C:\Users\John.julia\packages\IJulia\fjEtl\deps\build.log
WARNING: eval into closed module Base:
Expr(:block, #= Symbol(“C:\Users\John.julia\packages\Compat\hsya0\src\Compat.jl”):1891 =#, Expr(:call, :range, Expr(:parameters, Expr(:…, :kwargs)), :start, :stop) = Expr(:block, #= Symbol(“C:\Users\John.julia\packages\Compat\hsya0\src\Compat.jl”):1891 =#, Expr(:call, :range, Expr(:parameters, Expr(:kw, :stop, :stop), Expr(:…, :kwargs)), :start)))
** incremental compilation may be broken for this module **

WARNING: Method definition range(Any, Any) in module Base at range.jl:90 overwritten at C:\Users\John.julia\packages\Compat\hsya0\src\Compat.jl:1891.
WARNING: Method definition #range(Any, typeof(Base.range), Any, Any) in module Base overwritten.
WARNING: eval into closed module Base:
Expr(:block, #= Symbol(“C:\Users\John.julia\packages\Compat\hsya0\src\Compat.jl”):1891 =#, Expr(:call, :range, Expr(:parameters, Expr(:…, :kwargs)), :start, :stop) = Expr(:block, #= Symbol(“C:\Users\John.julia\packages\Compat\hsya0\src\Compat.jl”):1891 =#, Expr(:call, :range, Expr(:parameters, Expr(:kw, :stop, :stop), Expr(:…, :kwargs)), :start)))
** incremental compilation may be broken for this module **

WARNING: Method definition range(Any, Any) in module Base at range.jl:90 overwritten at C:\Users\John.julia\packages\Compat\hsya0\src\Compat.jl:1891.
WARNING: Method definition #range(Any, typeof(Base.range), Any, Any) in module Base overwritten.
[ Info: Installing Julia kernelspec in C:\Users\John\AppData\Roaming\jupyter\kernels\julia-1.1
------------------------------------MbedTLS
WARNING: eval into closed module Base:
Expr(:block, #= Symbol(“C:\Users\John.julia\packages\Compat\hsya0\src\Compat.jl”):1891 =#, Expr(:call, :range, Expr(:parameters, Expr(:…, :kwargs)), :start, :stop) = Expr(:block, #= Symbol(“C:\Users\John.julia\packages\Compat\hsya0\src\Compat.jl”):1891 =#, Expr(:call, :range, Expr(:parameters, Expr(:kw, :stop, :stop), Expr(:…, :kwargs)), :start)))
** incremental compilation may be broken for this module **

WARNING: Method definition range(Any, Any) in module Base at range.jl:90 overwritten at C:\Users\John.julia\packages\Compat\hsya0\src\Compat.jl:1891.
WARNING: Method definition #range(Any, typeof(Base.range), Any, Any) in module Base overwritten.
WARNING: eval into closed module Base:
Expr(:block, #= Symbol(“C:\Users\John.julia\packages\Compat\hsya0\src\Compat.jl”):1891 =#, Expr(:call, :range, Expr(:parameters, Expr(:…, :kwargs)), :start, :stop) = Expr(:block, #= Symbol(“C:\Users\John.julia\packages\Compat\hsya0\src\Compat.jl”):1891 =#, Expr(:call, :range, Expr(:parameters, Expr(:kw, :stop, :stop), Expr(:…, :kwargs)), :start)))
** incremental compilation may be broken for this module **

WARNING: Method definition range(Any, Any) in module Base at range.jl:90 overwritten at C:\Users\John.julia\packages\Compat\hsya0\src\Compat.jl:1891.
WARNING: Method definition #range(Any, typeof(Base.range), Any, Any) in module Base overwritten.
[ Info: Installing Julia kernelspec in C:\Users\John\AppData\Roaming\jupyter\kernels\julia-1.1
------------------------------------ZMQ
┌ Warning: platform_key() is deprecated, use platform_key_abi() from now on
│ caller = ip:0x0
└ @ Core :-1
┌ Warning: Could not extract the platform key of https://github.com/JuliaInterop/ZMQBuilder/releases/download/v4.2.5+6/ZMQ.x86_64-w64-mingw32.tar.gz; continuing…
└ @ BinaryProvider C:\Users\John.julia\packages\BinaryProvider\4F5Hq\src\Prefix.jl:185
[ Info: Downloading https://github.com/JuliaInterop/ZMQBuilder/releases/download/v4.2.5+6/ZMQ.x86_64-w64-mingw32.tar.gz to C:\Users\John.julia\packages\ZMQ\ABGOx\deps\usr\downloads\ZMQ.x86_64-w64-mingw32.tar.gz…
------------------------------------Conda
empty!

0 Likes

#8

To test the hypothesis that Julia 1.1 & IJulia don’t work, I uninstalled 1.1 & installed 1.0.3 & notebook() works now (as of 01/29/2019/TUE/9:50pm/ET)

0 Likes

#9

I also have a similar problem with IJulia, are there any ways to fix this using Julia 1.1.0?

0 Likes

#10

I stopped testing Julia: given the lack of response I concluded, for now, Julia isn’t stable/mature enough relative to the #of experts out there that are willing to help

0 Likes

#11

I got kind of the same idea - as i am a basic user, there is only so much i bother checking for errors before giving up, but i really want it to just work.

0 Likes

#12

@sloggers @kklocker I reported the same issue with IJulia on this discussion board.
I got some suggestions from two people and was able to solve the issue.

Please do nto abandon Julia because of this issue. If you were to abandon a language every time you came across a problem you would rapidly be using an abaqus.
This is a good and friendly community. Join in, stick with it and you will be givign advice to others sooner rather than later.

1 Like

#13

To make it clear, my issue was on Windows 10 and I had the PATH variable set to Julia 1.0.1 - which meant that IJulia did not build with version 1.1
Simple error, simple fix.

0 Likes

#14

When you do have 1.1 working with latest IJulia, please let us know the steps in detail.
Love to try it again.

0 Likes

#15

No problems. It is working!
May I ask which OS you are using?
Im my case windows 10 - I had to change the PATH variable which was set for an old Julia 1.0.1 installation.

My apologies - I read your initial post and it is Windows.
I would check your PATH variable.
Then in Pkg> remove IJulia
Pkg> add IJulia

0 Likes

#16

win8.1pro/64bit
uninstalled 1.0.3
uninstalled 1.1.0
fresh install 1.1.0
double checked PATH has h:\julia-1.1.0
** able to install IJulia now
** however, got internal error as shown below upon creation of new notebook with 1.1.0

[10] _start() at .\client.jl:436
in expression starting at C:\Users\John.julia\packages\IJulia\fjEtl\src\kernel.jl:1
[I 13:58:52.104 NotebookApp] KernelRestarter: restarting kernel (1/5), keep random ports
kernel 776ce152-4068-46e6-978d-1a09ad3eee31 restarted
[ Info: Precompiling IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a]
ERROR: LoadError: IJulia not properly installed. Please run Pkg.build(“IJulia”)
Stacktrace:
[1] error(::String) at .\error.jl:33
[2] top-level scope at none:0
[3] include at .\boot.jl:326 [inlined]
[4] include_relative(::Module, ::String) at .\loading.jl:1038
[5] include(::Module, ::String) at .\sysimg.jl:29
[6] top-level scope at none:2
[7] eval at .\boot.jl:328 [inlined]
[8] eval(::Expr) at .\client.jl:404
[9] top-level scope at .\none:3
in expression starting at C:\Users\John.julia\packages\IJulia\4UizY\src\IJulia.jl:45
ERROR: LoadError: Failed to precompile IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a] to C:\Users\John.julia\compiled\v1.1\IJulia\nfu7T.ji.
Stacktrace:
[1] error(::String) at .\error.jl:33
[2] compilecache(::Base.PkgId, ::String) at .\loading.jl:1197
[3] _require(::Base.PkgId) at .\loading.jl:960
[4] require(::Base.PkgId) at .\loading.jl:858
[5] require(::Module, ::Symbol) at .\loading.jl:853
[6] include at .\boot.jl:326 [inlined]
[7] include_relative(::Module, ::String) at .\loading.jl:1038
[8] include(::Module, ::String) at .\sysimg.jl:29
[9] exec_options(::Base.JLOptions) at .\client.jl:267
[10] _start() at .\client.jl:436
in expression starting at C:\Users\John.julia\packages\IJulia\fjEtl\src\kernel.jl:1
Internal error: encountered unexpected error in runtime:
InterruptException()
jl_mutex_unlock at /home/Administrator/buildbot/worker/package_win64/build/src\locks.h:138 [inlined]
jl_typeinf_end at /home/Administrator/buildbot/worker/package_win64/build/src\gf.c:2610
typeinf_ext at .\compiler\typeinfer.jl:577
typeinf_ext at .\compiler\typeinfer.jl:613
jfptr_typeinf_ext_1.clone_1 at H:\Julia-1.1.0\lib\julia\sys.dll (unknown line)
jl_apply_generic at /home/Administrator/buildbot/worker/package_win64/build/src\gf.c:2219 [inlined]
jl_apply at /home/Administrator/buildbot/worker/package_win64/build/src\julia.h:1571 [inlined]
jl_type_infer at /home/Administrator/buildbot/worker/package_win64/build/src\gf.c:277
jl_compile_method_internal at /home/Administrator/buildbot/worker/package_win64/build/src\gf.c:1819 [inlined]
jl_fptr_trampoline at /home/Administrator/buildbot/worker/package_win64/build/src\gf.c:1863
jl_apply_generic at /home/Administrator/buildbot/worker/package_win64/build/src\gf.c:2219
run_main_repl at .\client.jl:391
exec_options at .\client.jl:284
_start at .\client.jl:436
jl_apply_generic at /home/Administrator/buildbot/worker/package_win64/build/src\gf.c:2219
jl_apply at /home/Administrator/buildbot/worker/package_win64/build/src\julia.h:1571 [inlined]
true_main at /home/Administrator/buildbot/worker/package_win64/build/ui\repl.c:96
wmain at /home/Administrator/buildbot/worker/package_win64/build/ui\repl.c:217
__tmainCRTStartup at /usr/src/debug/mingw64-x86_64-runtime-5.0.3-1/crt\crtexe.c:329
mainCRTStartup at /usr/src/debug/mingw64-x86_64-runtime-5.0.3-1/crt\crtexe.c:212
BaseThreadInitThunk at C:\WINDOWS\system32\KERNEL32.DLL (unknown line)
RtlUserThreadStart at C:\WINDOWS\SYSTEM32\ntdll.dll (unknown line)
[I 13:58:58.114 NotebookApp] Interrupted…
[I 13:58:58.116 NotebookApp] Shutting down 1 kernel
[I 13:58:58.117 NotebookApp] Kernel shutdown: 776ce152-4068-46e6-978d-1a09ad3eee31

0 Likes

#17

I get almost the same error:
This was after i added julia to PATH.

(v1.1) pkg> remove IJulia
  Updating `C:\Users\KarlKristian\.julia\environments\v1.1\Project.toml`
  [7073ff75] - IJulia v1.17.0
  Updating `C:\Users\KarlKristian\.julia\environments\v1.1\Manifest.toml`
  [7073ff75] - IJulia v1.17.0
  [739be429] - MbedTLS v0.6.7
  [b85f4697] - SoftGlobalScope v1.0.9

(v1.1) pkg> add IJulia
  Updating registry at `C:\Users\KarlKristian\.julia\registries\General`
  Updating git-repo `https://github.com/JuliaRegistries/General.git`
 Resolving package versions...
  Updating `C:\Users\KarlKristian\.julia\environments\v1.1\Project.toml`
  [7073ff75] + IJulia v1.17.0
  Updating `C:\Users\KarlKristian\.julia\environments\v1.1\Manifest.toml`
  [7073ff75] + IJulia v1.17.0
  [739be429] + MbedTLS v0.6.7
  [b85f4697] + SoftGlobalScope v1.0.9

julia> using IJulia
[ Info: Precompiling IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a]

ERROR: LoadError: Blosc not installed properly, run Pkg.build("ZMQ"), restart Julia and try again
Stacktrace:
 [1] error(::String) at .\error.jl:33
 [2] top-level scope at C:\Users\KarlKristian\.julia\packages\ZMQ\ABGOx\src\ZMQ.jl:14
 [3] include at .\boot.jl:326 [inlined]
 [4] include_relative(::Module, ::String) at .\loading.jl:1038
 [5] include(::Module, ::String) at .\sysimg.jl:29
 [6] top-level scope at none:2
 [7] eval at .\boot.jl:328 [inlined]
 [8] eval(::Expr) at .\client.jl:404
 [9] top-level scope at .\none:3
in expression starting at C:\Users\KarlKristian\.julia\packages\ZMQ\ABGOx\src\ZMQ.jl:13

ERROR: LoadError: Failed to precompile ZMQ [c2297ded-f4af-51ae-bb23-16f91089e4e1] to C:\Users\KarlKristian\.julia\compiled\v1.1\ZMQ\CaaO6.ji.
Stacktrace:
 [1] error(::String) at .\error.jl:33
 [2] compilecache(::Base.PkgId, ::String) at .\loading.jl:1197
 [3] _require(::Base.PkgId) at .\loading.jl:960
 [4] require(::Base.PkgId) at .\loading.jl:858
 [5] require(::Module, ::Symbol) at .\loading.jl:853
 [6] include at .\boot.jl:326 [inlined]
 [7] include_relative(::Module, ::String) at .\loading.jl:1038
 [8] include(::Module, ::String) at .\sysimg.jl:29
 [9] top-level scope at none:2
 [10] eval at .\boot.jl:328 [inlined]
 [11] eval(::Expr) at .\client.jl:404
 [12] top-level scope at .\none:3
in expression starting at C:\Users\KarlKristian\.julia\packages\IJulia\4UizY\src\IJulia.jl:36

ERROR: Failed to precompile IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a] to C:\Users\KarlKristian\.julia\compiled\v1.1\IJulia\nfu7T.ji.
Stacktrace:
 [1] error(::String) at .\error.jl:33
 [2] compilecache(::Base.PkgId, ::String) at .\loading.jl:1197
 [3] _require(::Base.PkgId) at .\loading.jl:960
 [4] require(::Base.PkgId) at .\loading.jl:858
 [5] require(::Module, ::Symbol) at .\loading.jl:853

julia>

Building ZMQ after removing and adding shows

(v1.1) pkg> build ZMQ
  Building ZMQ → `C:\Users\KarlKristian\.julia\packages\ZMQ\ABGOx\deps\build.log`
┌ Error: Error building `ZMQ`:
│ ┌ Warning: platform_key() is deprecated, use platform_key_abi() from now on
│ │   caller = ip:0x0
│ └ @ Core :-1
│ ┌ Warning: Could not extract the platform key of https://github.com/JuliaInterop/ZMQBuilder/releases/download/v4.2.5+6/ZMQ.x86_64-w64-mingw32.tar.gz; continuing...
│ └ @ BinaryProvider C:\Users\KarlKristian\.julia\packages\BinaryProvider\4F5Hq\src\Prefix.jl:185
│ ERROR: LoadError: IOError: stat: invalid argument (EINVAL)
│ Stacktrace:
│  [1] stat(::String) at .\stat.jl:68
│  [2] isfile at .\stat.jl:303 [inlined]
│  [3] #install#133(::Prefix, ::String, ::Bool, ::Bool, ::Bool, ::Function, ::String, ::String) at C:\Users\KarlKristian\.julia\packages\BinaryProvider\4F5Hq\src\Prefix.jl:331
│  [4] (::getfield(BinaryProvider, Symbol("#kw##install")))(::NamedTuple{(:prefix, :force, :verbose),Tuple{Prefix,Bool,Bool}}, ::typeof(install), ::String, ::String) at .\none:0
│  [5] top-level scope at C:\Users\KarlKristian\.julia\packages\ZMQ\ABGOx\deps\build.jl:44
│  [6] include at .\boot.jl:326 [inlined]
│  [7] include_relative(::Module, ::String) at .\loading.jl:1038
│  [8] include(::Module, ::String) at .\sysimg.jl:29
│  [9] include(::String) at .\client.jl:403
│  [10] top-level scope at none:0
│ in expression starting at C:\Users\KarlKristian\.julia\packages\ZMQ\ABGOx\deps\build.jl:40
└ @ Pkg.Operations C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\Operations.jl:1075

(v1.1) pkg>
0 Likes

#18

I’m not familiar with using Julia on Windows, but maybe delete your .julia folder? This will remove all your packages. Then try installing IJulia and everything else again.

0 Likes

#19

Same error occured, it failes on ZMQ and MbedTLS, whatever those are.

(v1.1) pkg> add IJulia
   Cloning default registries into `C:\Users\KarlKristian\.julia`
   Cloning registry from "https://github.com/JuliaRegistries/General.git"
     Added registry `General` to `C:\Users\KarlKristian\.julia\registries\General`
 Resolving package versions...
 Installed SoftGlobalScope ─ v1.0.9
 Installed Conda ─────────── v1.2.0
 Installed Compat ────────── v1.5.1
 Installed ZMQ ───────────── v1.0.0
 Installed IJulia ────────── v1.17.0
 Installed BinaryProvider ── v0.5.3
 Installed JSON ──────────── v0.20.0
 Installed MbedTLS ───────── v0.6.7
 Installed VersionParsing ── v1.1.3
  Updating `C:\Users\KarlKristian\.julia\environments\v1.1\Project.toml`
  [7073ff75] + IJulia v1.17.0
  Updating `C:\Users\KarlKristian\.julia\environments\v1.1\Manifest.toml`
  [b99e7846] + BinaryProvider v0.5.3
  [34da2185] + Compat v1.5.1
  [8f4d0f93] + Conda v1.2.0
  [7073ff75] + IJulia v1.17.0
  [682c06a0] + JSON v0.20.0
  [739be429] + MbedTLS v0.6.7
  [b85f4697] + SoftGlobalScope v1.0.9
  [81def892] + VersionParsing v1.1.3
  [c2297ded] + ZMQ v1.0.0
  [2a0f44e3] + Base64
  [ade2ca70] + Dates
  [8bb1440f] + DelimitedFiles
  [8ba89e20] + Distributed
  [7b1f6079] + FileWatching
  [b77e0a4c] + InteractiveUtils
  [76f85450] + LibGit2
  [8f399da3] + Libdl
  [37e2e46d] + LinearAlgebra
  [56ddb016] + Logging
  [d6f4376e] + Markdown
  [a63ad114] + Mmap
  [44cfe95a] + Pkg
  [de0858da] + Printf
  [3fa0cd96] + REPL
  [9a3f8284] + Random
  [ea8e919c] + SHA
  [9e88b42a] + Serialization
  [1a1011a3] + SharedArrays
  [6462fe0b] + Sockets
  [2f01184e] + SparseArrays
  [10745b16] + Statistics
  [8dfed614] + Test
  [cf7118a7] + UUIDs
  [4ec0a83e] + Unicode
  Building Conda ──→ `C:\Users\KarlKristian\.julia\packages\Conda\CpuvI\deps\build.log`
  Building ZMQ ────→ `C:\Users\KarlKristian\.julia\packages\ZMQ\ABGOx\deps\build.log`
┌ Error: Error building `ZMQ`:
│ ┌ Warning: platform_key() is deprecated, use platform_key_abi() from now on
│ │   caller = ip:0x0
│ └ @ Core :-1
│ ┌ Warning: Could not extract the platform key of https://github.com/JuliaInterop/ZMQBuilder/releases/download/v4.2.5+6/ZMQ.x86_64-w64-mingw32.tar.gz; continuing...
│ └ @ BinaryProvider C:\Users\KarlKristian\.julia\packages\BinaryProvider\4F5Hq\src\Prefix.jl:185
│ [ Info: Downloading https://github.com/JuliaInterop/ZMQBuilder/releases/download/v4.2.5+6/ZMQ.x86_64-w64-mingw32.tar.gz to C:\Users\KarlKristian\.julia\packages\ZMQ\ABGOx\deps\usr\downloads\ZMQ.x86_64-w64-mingw32.tar.gz...
│ ERROR: LoadError: IOError: stat: invalid argument (EINVAL)
│ Stacktrace:
│  [1] stat(::String) at .\stat.jl:68
│  [2] isfile at .\stat.jl:303 [inlined]
│  [3] #install#133(::Prefix, ::String, ::Bool, ::Bool, ::Bool, ::Function, ::String, ::String) at C:\Users\KarlKristian\.julia\packages\BinaryProvider\4F5Hq\src\Prefix.jl:331
│  [4] (::getfield(BinaryProvider, Symbol("#kw##install")))(::NamedTuple{(:prefix, :force, :verbose),Tuple{Prefix,Bool,Bool}}, ::typeof(install), ::String, ::String) at .\none:0
│  [5] top-level scope at C:\Users\KarlKristian\.julia\packages\ZMQ\ABGOx\deps\build.jl:44
│  [6] include at .\boot.jl:326 [inlined]
│  [7] include_relative(::Module, ::String) at .\loading.jl:1038
│  [8] include(::Module, ::String) at .\sysimg.jl:29
│  [9] include(::String) at .\client.jl:403
│  [10] top-level scope at none:0
│ in expression starting at C:\Users\KarlKristian\.julia\packages\ZMQ\ABGOx\deps\build.jl:40
└ @ Pkg.Operations C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\Operations.jl:1075
  Building MbedTLS → `C:\Users\KarlKristian\.julia\packages\MbedTLS\XkQiX\deps\build.log`
┌ Error: Error building `MbedTLS`:
│ ┌ Warning: platform_key() is deprecated, use platform_key_abi() from now on
│ │   caller = ip:0x0
│ └ @ Core :-1
│ [ Info: Downloading https://github.com/JuliaWeb/MbedTLSBuilder/releases/download/v0.17.0/MbedTLS.v2.16.0.x86_64-w64-mingw32.tar.gz to C:\Users\KarlKristian\.julia\packages\MbedTLS\XkQiX\deps\usr\downloads\MbedTLS.v2.16.0.x86_64-w64-mingw32.tar.gz...
│ ERROR: LoadError: IOError: stat: invalid argument (EINVAL)
│ Stacktrace:
│  [1] stat(::String) at .\stat.jl:68
│  [2] isfile at .\stat.jl:303 [inlined]
│  [3] #install#133(::Prefix, ::String, ::Bool, ::Bool, ::Bool, ::Function, ::String, ::String) at C:\Users\KarlKristian\.julia\packages\BinaryProvider\4F5Hq\src\Prefix.jl:331
│  [4] (::getfield(BinaryProvider, Symbol("#kw##install")))(::NamedTuple{(:prefix, :force, :verbose),Tuple{Prefix,Bool,Bool}}, ::typeof(install), ::String, ::String) at .\none:0
│  [5] top-level scope at C:\Users\KarlKristian\.julia\packages\MbedTLS\XkQiX\deps\build.jl:48
│  [6] include at .\boot.jl:326 [inlined]
│  [7] include_relative(::Module, ::String) at .\loading.jl:1038
│  [8] include(::Module, ::String) at .\sysimg.jl:29
│  [9] include(::String) at .\client.jl:403
│  [10] top-level scope at none:0
│ in expression starting at C:\Users\KarlKristian\.julia\packages\MbedTLS\XkQiX\deps\build.jl:44
└ @ Pkg.Operations C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.1\Pkg\src\Operations.jl:1075
  Building IJulia ─→ `C:\Users\KarlKristian\.julia\packages\IJulia\4UizY\deps\build.log`
0 Likes

#20

TO find the dependencies of any package, go to the package home page, for instance


Then look in the REQUIRE file. You will have to do a little searching to find the package home pages.

0 Likes