Why julia exit from REPL?

Hi,
an oddity in the early morning …

I am in REPL (on windows 10). Julia exit from REPL … but why???

julia> x = 1
1

julia> x = [1,2,3,4]

C:\vmswap\juliaPrj\querere>

It exits ? … due to what ???
Did something break in my Julia installation?

Can you replicate this behavior reliably? What do you press after the last ]?

I start julia repl, i write “x = [1,2]” i hit return and julia repl exits …

c:\vmswap\juliaPrj\querere>julia
               _
   _       _ _(_)_     |  Documentation: https://docs.julialang.org
  (_)     | (_) (_)    |
   _ _   _| |_  __ _   |  Type "?" for help, "]?" for Pkg help.
  | | | | | | |/ _` |  |
  | | |_| | | | (_| |  |  Version 1.3.1 (2019-12-30)
 _/ |\__'_|_|_|\__'_|  |  Official https://julialang.org/ release
|__/                   |

julia> x = [1 ,2]

c:\vmswap\juliaPrj\querere>

That is not supposed to happen. Many people including myself are using Julia on Windows and it works perfectly fine. It is hard to figure out what’s going on, in particular because there is no error message. I guess the first thing to try is to do a fresh install of Julia and perhaps also delete your ~/.julia folder.

Is there anything in your startup.jl file? Or have you modified any other config files? Environmental variables?

1 Like

Could be some weird customization in your environment or startup file. Did you change anything recently, eg

Thanks to all …

Yesterday I reinstalled several times in effect, due to that environment variable needed in taro.jl …
I tried PDFIO.jl and it seems to me it works well on pdf, so I won’t use taro.jl.
I try to reinstall everything, then I can tell you …
It also seems to me that Juno is going a little bad, that is, he is slow to start Julia … ok, I reinstall everything.

I disintall and delete .atom , .julia ecc …

Handcuffing, I thought that maybe there are several bugs under windows, but if you say so, I think I can trust …

Since Julia’s scope is academic, I thought maybe Julia was more stable in osx / linux / unix. Isn’t that so?

Since you use windows, what editor do you use? juno or visualcode? or other?

Reinstalling stuff is probably overkill, I would start with rolling back changes in config files.

Emh … what should I do ??

Revert changes that you made before it stopped working. But we cannot tell what those changes were.

Since you are not providing the information requested (eg what @Skoffer asked for), I am sorry but I cannot help you.

1 Like

I reproduced the issue with setting
set JULIA_COPY_STACKS=1
as you did in

So, you should remove this environment variable again.

Than I created a new julia environment to check Taro.jl and added it without any problem:

(v1.3) pkg> activate .
Activating new environment at `C:\Users\USER\.julia\environments\Taro\Project.toml`

(Taro) pkg> add Taro.jl
 Resolving package versions...
 Installed WinReg ─── v0.3.1
 Installed JavaCall ─ v0.7.3
 Installed Taro ───── v0.8.0
  Updating `C:\Users\USER\.julia\environments\Taro\Project.toml`
  [61d0e4fa] + Taro v0.8.0
  Updating `C:\Users\USER\.julia\environments\Taro\Manifest.toml`
  [9a962f9c] + DataAPI v1.1.0
  [864edb3b] + DataStructures v0.17.10
  [e2d170a0] + DataValueInterfaces v1.0.0
  [82899510] + IteratorInterfaceExtensions v1.0.0
  [494afd89] + JavaCall v0.7.3
  [bac558e1] + OrderedCollections v1.1.0
  [3783bdb8] + TableTraits v1.0.0
  [bd369af6] + Tables v0.2.11
  [61d0e4fa] + Taro v0.8.0
  [1b915085] + WinReg v0.3.1
  [2a0f44e3] + Base64
  [ade2ca70] + Dates
  [8ba89e20] + Distributed
  [b77e0a4c] + InteractiveUtils
  [8f399da3] + Libdl
  [37e2e46d] + LinearAlgebra
  [56ddb016] + Logging
  [d6f4376e] + Markdown
  [de0858da] + Printf
  [9a3f8284] + Random
  [9e88b42a] + Serialization
  [6462fe0b] + Sockets
  [8dfed614] + Test
  [4ec0a83e] + Unicode
  Building Taro → `C:\Users\USER\.julia\packages\Taro\B3v9c\deps\build.log`

julia> versioninfo()
Julia Version 1.3.1
Commit 2d5741174c (2019-12-30 21:36 UTC)
Platform Info:
  OS: Windows (x86_64-w64-mingw32)
  CPU: Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz
  WORD_SIZE: 64
  LIBM: libopenlibm
  LLVM: libLLVM-6.0.1 (ORCJIT, haswell)
Environment:
  JULIA_PKGDIR = c:\Program Files\Julia-0.6.2\packages\
  JULIA_SHELL = C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe

So, I am afraid, that your windows system is somehow messy.

1 Like

Mmmm … to delete everything, i have to disinstall julia from control panel -> programs … and the same for juno … after i delete c:\users\dario.julia and c:\users\dario.juno …

Do I forget something else to start from scratch? mmm, restarting windows …

Ok, i delete Juno, reinstalled Juia, and now i am usign Visual Studio Code.
I see it is not necessary to reinstall anything in Visual Studio Code, it works all again.
Many thanks to all.

I can not believe it … the REPL broke again … I worked this time with Visual Studio Code and Julia in the afternoon and everything was fine, reboot tonight, and here you are again that the REPL does not work … this time I have not dealt with any variable system …

C:\Users\dario>julia
               _
   _       _ _(_)_     |  Documentation: https://docs.julialang.org
  (_)     | (_) (_)    |
   _ _   _| |_  __ _   |  Type "?" for help, "]?" for Pkg help.
  | | | | | | |/ _` |  |
  | | |_| | | | (_| |  |  Version 1.3.1 (2019-12-30)
 _/ |\__'_|_|_|\__'_|  |  Official https://julialang.org/ release
|__/                   |

julia> x=[1,2]

C:\Users\dario>

I have restart windows now, i test again the same x=[1,2] in repl, and now it does NOT break.

Well … at least it is not something that concerns Juno, because I no longer have it installed, and I am using Visual Studio Code. But the breaking of the REPL, it happened even if I started from a command prompt …

But now works ok …