I tried to register a package that contains:
DiffEqBase = "<6.116.0"
Sundials = "~4.11"
and get the error message:
The following dependencies do not have a [compat] entry that is upper-bounded
and only includes a finite number of breaking releases: DiffEqBase
What is the best way to fix that? DiffEqBase 6.116.0 is broken, but older versions work. How can
I define this such that Julia registrator accepts it?
Probably something like
6.0.0-6.115 works. (You probably don’t want to support major versions lower than 6, do you?)
Ps. All versions after 6.116 are broken? In what sense? Wouldn’t it be better to fill a bug report in that case?
This doesn’t work:
DiffEqBase = "6.0.0-6.115"
But this works:
DiffEqBase = "6.0.0 - 6.115"
(Spaces are important).
Uhm… Maybe add some spaces?
I understand that should work, though.
This is from the manual:
PkgA = "1.2.3 - 4.5" # 1.2.3 - 4.5.*
Yes, we require the spaces before and after the hyphen.