Which Plot packages works perfectly on Julia 1.0.0


#1

Which Plot packages works perfectly on Julia 1.0.0

I tried to find documentation for this but there is none showing which of these works on Julia 1.0.0 and which only works on Julia 0.6 or earlier

BACKENDs
PyPlot
Plotly
PlotlyJS
GR
UnicodePlots
PGFPlots
InspectDR
HDF5

FRONTEND
Plots

ALONEBYITSELF
Gadfly

Regards


#2

I am using Plots and Gadfly#master and both seem to work fine on Win 10.


#3

For the latest updates on Gadfly see:


#4

#5

Gadfly is there if you add Gadfly#master


#6

Packages usually have CI badges that show status on 1.0, but this information is not aggregated automatically.

There is also


#7

For example,

I could not for the life of me by looking at this URL below

figure out if the GR backend is working for Julia 1.0.0

Perhaps someone can tell me how to tell if it is compatible with Julia 1.0.0
Regards
Steven Siew


#8

" Gadfly is there if you add Gadfly#master" says jerryling315

How do I do that? Do I do

julia>
(v1.0) pkg>  add  Gadfly#master

then stop and restart the REPL?


#9

well then just
julia> using Gadfly


#10

You can go through the releases made after Julia 1.0 is announced, if any of their notes say v1.0 support, then that’s your answer. GR v0.32.1 says “Add support for Julia 1.0.0”. Or you can simply try ] adding it, if it installs correctly with the new automatic capping, then most likely it works on Julia v1.0. But just to be sure, run ] test pkg_name in the REPL to run the unit tests of the package. Then if all tests pass, you can run your own examples and make sure they work fine using the API of the latest stable release.


#11

These are packages on their own. If you have issues with Plots.jl this is not related to theses packages. What you call “Frontend” is also pretty limited. My frontend is PyPlot and it works pretty well on Julia 1.0.


#12

VegaLite.jl also works well on 1.0


#13

Gadfly not (yet) working for me:

(v1.0) pkg> add Gadfly#master
  Updating git-repo `https://github.com/GiovineItalia/Gadfly.jl.git`
 Resolving package versions...
  Updating `~/.julia/environments/v1.0/Project.toml`
 [no changes]
  Updating `~/.julia/environments/v1.0/Manifest.toml`
 [no changes]

julia> using Gadfly
[ Info: Precompiling Gadfly [c91e804a-d5a3-530f-b6f0-dfbca275c004]
ERROR: LoadError: syntax: try without catch or finally
Stacktrace:
 [1] include at ./boot.jl:317 [inlined]
 [2] include_relative(::Module, ::String) at ./loading.jl:1038
 [3] include(::Module, ::String) at ./sysimg.jl:29
 [4] top-level scope at none:2
 [5] eval at ./boot.jl:319 [inlined]
 [6] eval(::Expr) at ./client.jl:389
 [7] top-level scope at ./none:3

#14

I believe you also need Compose#master https://github.com/GiovineItalia/Gadfly.jl/issues/1185#issuecomment-421470799


#15

Yes that is true


#16

For Julia 1.0.0

to get Gadfly to work

julia>
(v1.0) pkg> add Compat
(v1.0) pkg> add Compose#master
(v1.0) pkg> add Gadfly#master
(v1.0) pkg> add Hexagons

to test
restart REPL
julia> using Gadfly
julia> plot(y=[1,2,3])

#17
BACKENDs
PyPlot        "seems to work in Julia 1.0.0"
Plotly
PlotlyJS
GR                 "seems to work in Julia 1.0.0"
UnicodePlots      "seems to work in Julia 1.0.0"
PGFPlots
InspectDR
HDF5

FRONTEND
Plots                          "seems to work in Julia 1.0.0"

ALONEBYITSELF
Gadfly                        "requires specific procedure to work in julia 1.0.0 (see notes)"

Gadfly notes:
    julia>
    (v1.0) pkg> add Compat
    (v1.0) pkg> add Compose#master
    (v1.0) pkg> add Gadfly#master
    (v1.0) pkg> add Hexagons

    to test
    restart REPL
    julia> using Gadfly
    julia> plot(y=[1,2,3])


#19

The latest stable release of Gadfly now supports Julia 1.0: Gadfly, the native Julia statistical plotting library, adds Julia 1.0 support!

I’ve been using it exclusively on 1.0 for over a month and it’s been solid. We’re actively squashing a bunch of old bugs and so it’s probably even better than on Julia v0.6.2. Let us know if you run into any issues!


#20

I might be the only person who uses it, but ECharts.jl works fine on 1.0 also.


#21

I guess that the Travis badge showing failed CI may discourage some people from trying it out.