Where does Julia in VS Code specify startup shell commands if not within startup.jl?

For some reason when the Julia REPL starts within VSCode when I hit shift-enter on my first line of Julia code a = 1 contained within a .jl file I get:

source /Users/gardnera/tools/miniconda3/bin/activate
julia> urce /Users/gardnera/tools/miniconda3/bin/activate

julia> soERROR: UndefVarError: urce not defined
 [1] top-level scope
   @ REPL[1]:1

To me it seems like source /Users/gardnera/tools/miniconda3/bin/activate is suppose to be executed as a shell command before the Julia REPL is initiated but for some reason it is trying to be executed at the REPL.

The change in behavior seemed to come out of nowhere.

Strangely, starting Julia from the terminal within VS Code does not result in this error. And there is nothing within the startup.jl file.

1 Like

This is likely one of your Python plugins misbehaving, not the Julia plugin.


As per Using Python Environments in Visual Studio Code

Tip: To prevent automatic activation of a selected environment, add "python.terminal.activateEnvironment": false to your settings.json file (it can be placed anywhere as a sibling to the existing settings).

1 Like