VS code triggers anti-malware


#1

Version 1.19.3
Commit 7c4205b5c6e52a53b81c69d2b2dc8a627abaa0ba
Date 2018-01-25T10:36:34.867Z
Shell 1.7.9
Renderer 58.0.3029.110
Node 7.9.0
Architecture x64

Every time I do something in the terminal anti-malware kicks into action and consumes huge amounts of CPU time. I use the git bash in the terminal, but I checked just the bash in its own terminal outside of VS code, and no such anti-malware software activity is detected.

Could someone who is also using Windows 10 check on their own system please? Perhaps I’m not the only one, in which case it might become easier to track down and fix.


#2

I am also using vs code with Julia, is there a work space panel in the most recent vs code julia? I kept receiving update notice, but could not update my vs code on my fedora machine with terminal command. It seems I need to uninstall it first, and then reinstall the most recent version. If there is no breaking changes, I will not update my vscode.


#3

I’m not experiencing this. I’m on Win 10 as well. I just have the default Windows anti virus running.


#4

I’m not seeing this problem on either my work Windows 8 laptop with McAfee antivirus or on my home laptop with Windows 10 and Kaspersky antivirus.


#5

Not experiencing it and I’ve been using the REPL heavily lately. I also switched my terminal to git-bash from powershell and also no problems when it launches. Virus Scanner is just windows defender.

Version 1.19.3
Commit 7c4205b5c6e52a53b81c69d2b2dc8a627abaa0ba
Date 2018-01-25T10:36:34.867Z
Shell 1.7.9
Renderer 58.0.3029.110
Node 7.9.0
Architecture x64


#6

Thanks to all who replied. This is what it looks like on my laptop. Note how the activity of the Windows Defender is correlated with me opening and closing VS Code.

Perhaps I should uninstall VS Code and wipe all traces of it and start with a clean slate. But then it would not be possible to debug this issue. On the other hand, no one else seems to be having trouble…


#7

So the only vague theory I have is that when you open your package root folder with all packages in it, our language server will be extremely busy, because it will try to analyze all the packages at startup. I don’t know why that would trigger the AV, but maybe it does in some way…


#8

Thanks for trying to figure it out. I suspect there is more to it than that though. One would expect the language server to be done after a while, but I just let VS code set alone for an hour, and then I tried listing the folder again. Still the same abysmal performance where one can see the text appearing letter by letter.

At this point I will resort to a reinstallation from scratch.


#9

I can’t pin it down, but using Atom the windows defender went haywire for a while, taking up almost all resources…but it might have been when updating packages.


#10

I have seen this on two separate Windows computers. I have just turned off Windows Defender to deal with it. As to why it is happening I have no idea. I did wipe both computers for other reasons recently and they still have that issue.


#11

IIRC I’ve seen something similar as well – “solved” it by excluding ~/.julia from the list of folders Windows Defender watches.


#12

Is this something that windows defender allows as part of an installation process (thinking juliapro here…) obviously user needs to confirm, but is it even possible?


#13

There is also that pop-up from defender when things try to do internet access and asks what types of networks are allowed … Is this something that can be set correctly in installation? I always worry I have made the wrong choice.