VS Code Extension Error


My VS Code could not start Julia since Julia Extension 1.4.0 (till latest 1.5.5).

There is an error saying the julia executable path is not correct. However, it is actually right.

When I go back to the older version 1.3.34, there is no such error and Julia can be started.

I have tried several messures, like uninstall VS Code, Julia and reinstall them.

May I have your help to see how to solve the issue?

Thanks & B.Rgds.

VS Code Julia Extension Error

The issue was solved. I found it was caused due to some modification since version 1.4.0.

Open “.vscode\extensions\julialang.language-julia-1.5.6\package.json” (as below screenshot),change ”configuration”–>”julia.executablePath”–>”scope” from ”machine-overridable” into ”machine”, i.e. the same as in version 1.3.34.

Restart VS Code, then Julia can be started.

VS Code Julia Extension Modification

That sounds like you have a workspace configuration that changes the julia path to something that doesn’t exist.


Thanks so much for your message.
Yes, it is. The workspace configuration changes the user configuration.

I am not familiar with workspace and never configurated or changed it previously. So I did not realize that is the reason causing the issue.

Now I modified the workspace configuration and it works properly.

Thanks again.

1 Like