Valid path to Julia executable in VS Code on MacOS?

I installed julia-1.6, VS Code, and setting julia.executablePath.
When I try to run one of my Julia codes, I keep getting the message:
“Could not start the Julia language server. Make sure the configuration setting julia.executablePath points to the Julia binary.”
The last version of the path I tried is:

Does anybody know how to solve this? Perhaps an example of a path that works on MacOS-12?

Aren’t you missing a slash at the start there?



A slash at the start didn’t help

Very good: the “.app” did it. No more warnings. Thank you!

Next problem: when I click on “run and debug”, nothing happens.
No output, no problems detected in the workspace

1 Like

I think that “run and debug” works when you place yourself in a properly defined Julia project.
You may take a look at this introductory video

if you can survive my english :wink:


Thank you (Merci a vous, abonné)
for those of you interested, he’s a humble teacher with a a good presentation :smile:


Thank you for your comment. I’ve watched your video and I could easily survive your english, but it’s out of the question that I could survive the complexity of the procedure in the video. Being an old statistician, it’s just out of reach for me.

Until a year ago I used julia-1.0 without creating a project, and that worked fine. I did not need a project either, because I have only one programming job to do.

Can’t I go ahead with programming without a project?

Sorry about that. I hope that the problem is the video quality that mix probably too many subjects in a short time (vscode and julia install, Project creation with pkgskeleton, github repo, Revise).

I think that Julia really shines when you start to use projects.

I have just checked that I can use “run and debug” on a simple julia script:

Note that I use option-O option-J to launch Julia on vscode (Alt-J Alt-O on Linux/Windows)

Hope it helps.