Upgrade 0.6.2 -> 0.6.3, IJulia problem?


#1

I just upgraded from Julia 0.6.2 to 0.6.3. Here is what I did:

  • uninstall Julia 0.6.2
  • install Julia 0.6.3
  • Pkg.update()

When I ran using IJulia + notebook() and opened a notebook, I got a Kernel error, and noticed that the kernel was listed as v. 0.6.2.

  • Is this the expected behavior?
  • Do I need to remove all packages and re-adding them?

I did do Pkg.rm("IJulia") and then added it again, and now the notebook works…

So… essentially, my question is:
Q: What is the expected action when upgrading Julia versions?


#2

The process is slightly buried in the readme of iJulia.jl (I have to go and look it up everytime I upgrade!)

Essentially you just need to run
Pkg.build("IJulia")
From the REPL of your new Julia (in this case 0.6.3) instance.


#3

There’s also an installkernel function demoed in that README, that’s worth knowing about if you want to start Julia with any compiler flags:

IJulia.installkernel("Julia nodeps", "--depwarn=no")

#4

Thanks for tip. I did Pkg.rm("IJulia") followed by Pkg.add("IJulia"), and that allowed me to start up IJulia with the correct kernel. I still do have problems running a notebook that used to work under Julia v. 0.6.2, so I tried to subsequently do Pkg.build("IJulia") – seemed to work, but there was an error message referring to kernel-spec or something; still the notebook started (but couldn’t execute as before; see separate thread).


#5

At the menu on top of the notebook, did you try
Kernel -> Change Kernel -> [select 0.6.3]
?

Notebooks save which kernel you used, so it will open with what you used last time.