Update Problem-Julia in Mac OS

Hello everybody

I tried to update my Julia and then update JuMP,
Because I have the following Error in my code:

ERROR: UndefVarError: `Model` not defined
 [1] solve_are(A::Matrix{Float64}, B::Matrix{Float64}, Q::Matrix{Float64})
   @ Main /Volumes/シャララ/University/Codes/Julia/Keep_SOF_main.jl:16
 [2] top-level scope
   @ /Volumes/シャララ/University/Codes/Julia/Keep_SOF_main.jl:124```

while I tried to update Julia:

using Pkg
using UpdateJulia
update_julia() ```

```Julia Version 1.10.2
Commit bd47eca2c8a (2024-03-01 10:14 UTC)
Build Info:
  Official https://julialang.org/ release
Platform Info:
  OS: macOS (arm64-apple-darwin22.4.0)
  CPU: 8 × Apple M2
  LIBM: libopenlibm
  LLVM: libLLVM-15.0.7 (ORCJIT, apple-m1)
Threads: 1 default, 0 interactive, 1 GC (on 4 virtual cores)
   Resolving package versions...
   Installed UpdateJulia ─ v0.4.4
   Installed Suppressor ── v0.2.6
    Updating `~/.julia/environments/v1.10/Project.toml`
  [770da0de] + UpdateJulia v0.4.4
    Updating `~/.julia/environments/v1.10/Manifest.toml`
  [fd094767] + Suppressor v0.2.6
  [770da0de] + UpdateJulia v0.4.4
Precompiling project...
  ✓ Suppressor
  ✓ UpdateJulia
  2 dependencies successfully precompiled in 3 seconds. 585 already precompiled. 3 skipped during auto due to previous errors.
No valid download for "" matching os="macos" and arch="aarch64"

 [1] error(s::String)
   @ Base ./error.jl:35
 [2] v_url(version_str::String, os_str::String, arch_str::String, prefer_gui::Bool)
   @ UpdateJulia ~/.julia/packages/UpdateJulia/nPbih/src/UpdateJulia.jl:125
 [3] update_julia(version::String)
   @ UpdateJulia ~/.julia/packages/UpdateJulia/nPbih/src/UpdateJulia.jl:166
 [4] update_julia()
   @ UpdateJulia ~/.julia/packages/UpdateJulia/nPbih/src/UpdateJulia.jl:161
 [5] top-level scope
   @ /Volumes/シャララ/University/Codes/Julia/Importan_Julia.ipynb:7```

I am not familiar with MacOS. However the UpdateJulia package is no longer maintained

I would suggest using Juliaup - I use it and it prevents a lot of wailing and gnashing of teeth.

1 Like

Thank you for your response,

I tried to do what you mentioned, but:

curl -fsSL https://install.julialang.org | sh

info: downloading installer

Welcome to Julia!

It seems that Juliaup is already installed on this system. Please remove the previous installation of Juliaup before you try to install a new version.

I think that might be juliaup noting that Julia is already installed.
How did you install Julia? I think you will have to completely uninstall Julia.
Then use juliaup

I downloaded it from Julia’s main page and just put the shortcut in the Application folder. I am confused, if possible please clarify it for me.

What happens when you run juliaup status

I misread your first report after installing juliaup. Sorry.

Please see here:

juliaup status
Default Channel Version Update

   *  release  1.10.2+0.aarch64.apple.darwin14

Use juliaup update to update Julia, not the UpdateJulia.jl package

Now what happens when you try to update the JuMP package in the REPL?
I would remove the UpdateJulia package also

I did all and now, JuMP can be updated properly without any problem…
Thank you so much, But still it seems this package does not work properly.

I wanted to update JuMP because I received a non-logical mathematical Error…

Please help me on this case too:

I am trying to solve an LMI problem, this is my example:

A = [2 -1; 1 3] # A to have dimensions (2,2)
B = [1; 0] # B to have dimensions (2,1)

ERROR: DimensionMismatch: matrix A has dimensions (2,1), matrix B has dimensions (2,2)

Why it shows the wrong dimensions?
while dimensions are true, how can I pass this error?

Err… what happens in the REPL if you simply print out A and B fter dfining them


julia> println(A);println(B)
[2 -1; 1 3]
[1, 0]

julia> size(A)
(2, 2)

julia> size(B)