Unable to update to latest version of Pluto v0.19.14

Hi Julia members,

I need help as below, which it is unable to update to latest version of Julia @ v0.19.14. Kindly refer to the message below

(@v1.8) pkg> add Pluto@v0.19.14
Resolving package versions…
ERROR: Unsatisfiable requirements detected for package Blink [ad839575]:
Blink [ad839575] log:
├─possible versions are: 0.8.0-0.12.5 or uninstalled
└─restricted by compatibility requirements with Mux [a975b10e] to versions: uninstalled — no versions left
└─Mux [a975b10e] log:
├─possible versions are: 0.4.0-1.0.1 or uninstalled
└─restricted by compatibility requirements with HTTP [cd3eb016] to versions: 1.0.0-1.0.1 or uninstalled
└─HTTP [cd3eb016] log:
├─possible versions are: 0.6.10-1.5.1 or uninstalled
└─restricted by compatibility requirements with Pluto [c3e4b0f8] to versions: 1.0.2-1.5.1
└─Pluto [c3e4b0f8] log:
├─possible versions are: 0.2.0-0.19.14 or uninstalled
└─restricted to versions 0.19.14 by an explicit requirement, leaving only versions 0.19.14

Many Thanks

Ok this is a bit cryptic - I think after looking this up the problem is that Blink.jl is restricted to Mux.jl v0.7 which uses HTTP.jl <1.0, but Pluto now requires HTTP.jl >1.0 .

So there are the following possibilities:

  • Separate the projects using Blink and Pluto into different environments. This is the general recommendation - I guess if you run a pluto notebook, you don’t need Blink. You could for instance call Pluto always with Julia started by
julia --project=@pluto

This creates a separate environment where you just add Pluto.

  • If you must use them together, you are “stuck” with an older Pluto which still may work well
  • If it is a necessity for survival to have both Blink and newest Pluto, kindly ask the Blink developers to update their dependencies - either via an issue or - after trying the updaete yourself - via a PR.