Unable to run Julia in Atom

I was using Julia v 0.64 ( I need to use a code written in this version) in Atom in the last months without any issues.
Today the REPL was not able to start Julia exting all time.
I so uninstalled and reinstalled again both Julia, Atom and all the related folders.
Now it gives me this error-

Press Enter to start a new session.
ERROR: LoadError: UndefVarError: @error not defined
[1] include_from_node1(::String) at .\loading.jl:576
[2] include(::String) at .\sysimg.jl:14
[3] process_options(::Base.JLOptions) at .\client.jl:305
[4] _start() at .\client.jl:371
while loading C:\Users\gcalajo.atom\packages\julia-client\script\boot_repl.jl, in expression starting on line 1

I retried to repeat uninstall and reinstall again and give me always the same error.
Someone can help?


Thanks for answering, but where it should go this script?

I think if you drop that boot_reql.jl in ~/.atom/packages/julia-client/scripts and start atom that will probably work. I would save the original file just in case.


Do note that the script in that PR was actually incorrect – please use this version instead or wait for the next release of julia-client.

Thanks a lot!Now with the new script it is working again.
The only (not big I guess) issue is that is remaining a warning:
WARNING: Atom.jl: unrecognised message updateeditor.

It is something that can be fix or it will remain for this version?

I don’t think there will be any further updates to Atom.jl for Julia 0.6. You can however add

handle("updateeditor") do data

to this file locally, which will get rid of the warning.

Thanks a lot again for the help!.

Hello, this didn’t worked for me. I added that to the file and the warning messages still appears.

EDIT: Actually, i have edited the wrong misc.jl file. Could you tell me where exactly that file i need to modify is in Windows?

I’ve been looking inside this path:


And, inside that Atom folder, there are 2 more folders witch contains a misc.jl file, but none of them looks like the one you posted here.