Trouble installing julia-client@0.13.11 in Manjaro Linux

Hi, I have some trouble installing julia-client and I hope someone can help, thank you very much.
These are my versions
Atom : 1.41.0
Electron: 4.2.12
Chrome : 69.0.3497.128
Node : 10.11.0
npm version 6.4.1
nvm version v10.11.0
julia version 1.2.0
Python 3.7.4

And here is the problem

Installing “julia-client@0.11.3” failed.Hide output…

node-pty-prebuilt-multiarch@0.9.0 install /tmp/apm-install-dir-1191011-6761-y3hiv3.52fuo/node_modules/julia-client/node_modules/node-pty-prebuilt-multiarch
prebuild-install || node scripts/install.js

node-pty-prebuilt-multiarch@0.9.0 postinstall /tmp/apm-install-dir-1191011-6761-y3hiv3.52fuo/node_modules/julia-client/node_modules/node-pty-prebuilt-multiarch
node scripts/post-install.js

julia-client@0.11.3 postinstall /tmp/apm-install-dir-1191011-6761-y3hiv3.52fuo/node_modules/julia-client
node script/postinstall.js

npm WARN lifecycle The node binary used for scripts is /home/uriel/.nvm/versions/node/v8.0.0/bin/node but npm is using /usr/bin/node itself. Use the --scripts-prepend-node-path option to include the path for the node binary npm was executed with.
/tmp/apm-install-dir-1191011-6761-y3hiv3.52fuo/node_modules/julia-client/script/postinstall.js:5
fs.copyFileSync(__dirname + ‘/…/keymaps/julia-client.cson’ + suffix, __dirname + ‘/…/keymaps/julia-client.cson’)
^

TypeError: fs.copyFileSync is not a function
at copyKeymaps (/tmp/apm-install-dir-1191011-6761-y3hiv3.52fuo/node_modules/julia-client/script/postinstall.js:5:6)
at Object. (/tmp/apm-install-dir-1191011-6761-y3hiv3.52fuo/node_modules/julia-client/script/postinstall.js:8:1)
at Module._compile (module.js:569:30)
at Object.Module._extensions…js (module.js:580:10)
at Module.load (module.js:503:32)
at tryModuleLoad (module.js:466:12)
at Function.Module._load (module.js:458:3)
at Function.Module.runMain (module.js:605:10)
at startup (bootstrap_node.js:158:16)
at bootstrap_node.js:575:3
npm WARN enoent ENOENT: no such file or directory, open ‘/tmp/apm-install-dir-1191011-6761-y3hiv3.52fuo/package.json’
npm WARN apm-install-dir-1191011-6761-y3hiv3.52fuo No description
npm WARN apm-install-dir-1191011-6761-y3hiv3.52fuo No repository field.
npm WARN apm-install-dir-1191011-6761-y3hiv3.52fuo No README data
npm WARN apm-install-dir-1191011-6761-y3hiv3.52fuo No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! julia-client@0.11.3 postinstall: node script/postinstall.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the julia-client@0.11.3 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/uriel/.atom/.apm/_logs/2019-11-11T06_40_48_993Z-debug.log

Try installing uber-juno because Julia-client has some dependencies that may not get installed automatically.
https://atom.io/packages/uber-juno

Hm, I’m on Manjaro as well and installing works just fine for me. Can you try

apm install julia-client

in a terminal?

Also, how did you install Atom?

I’ve tried with uber-juno first but the problem appears when it tries to install julia-client. That’s why I tried to install just the julia-client package.

Also have tried with to installed with the terminal, but the same error appears.

I installed atom with the package manager of Manjaro.

What’s the output of node -v in a terminal?

Now is v8.0.0 but I have nvm to move from one node version to another, I think maybe the problem is related to that

Yeah, for some reason apm is picking up your global node installation, and you need at least version 8.5 for the postinstall script to succeed. Try switching to something a bit newer, like node 10, and try again.

Oh I didn’t know that I needed 8.5 version of node. you were right, I updated gobally and it worked. Thank you very much.