Travis CI ERROR: Repository not found. fatal: Could not read from remote repository

I am finalizing a package on Fourier Analysis of multivariate time-series
hosted on GitHub here.

For deploying the documentation i followed the directions in Documenter’s Hosting Documentation and
SSH Deploy Keys Walkthrough pages.

I generated SSH keys with PuTTY (I work on Windows 10) and used Travis CI for deployement.

When Travis runs the docs make.jl i get the following error:

329 ERROR: Repository not found.

330 fatal: Could not read from remote repository.

I tried to generate the keys again and that did not help.

Anybody as a clue what is going wrong?

The complete Travis log is here below.
The complete code I am using is in the public repository of the package

Thanks!

The command “julia --project=docs/ -e ‘using Pkg; Pkg.develop(PackageSpec(path=pwd())); Pkg.instantiate()’” exited with 0.

300190.04s$ julia --project=docs/ docs/make.jl

301

302​:star: Welcome to the FourierAnalysis package :star:

303

304[ Info:

305 Your Machine travis-job-e9be1085-25b3-41ac-bb91-c65b280edc51 (x86_64-pc-linux-gnu)

306 runs on kernel Linux with word size 64.

307 CPU Threads: 2

308 Base.Threads: 1

309 BLAS Threads: 1

310

311[ Info: SetupBuildDirectory: setting up build directory.

312[ Info: Doctest: running doctests.

313[ Info: ExpandTemplates: expanding markdown templates.

314[ Info: CrossReferences: building cross-references.

315[ Info: CheckDocument: running document checks.

316[ Info: Populate: populating indices.

317[ Info: RenderDocument: rendering document.

318[ Info: HTMLWriter: rendering HTML pages.

319┌ Info: Deployment criteria:

320│ - :heavy_check_mark: ENV[“TRAVIS_REPO_SLUG”]=“Marco-Congedo/FourierAnalysis” occurs in repo=“github.com/Marco-Congedo/FourierAnalysis.jl.git

321│ - :heavy_check_mark: ENV[“TRAVIS_PULL_REQUEST”]=“false” is “false”

322│ - :heavy_check_mark: ENV[“TRAVIS_TAG”]="" is (i) empty or (ii) a valid VersionNumber

323│ - :heavy_check_mark: ENV[“TRAVIS_BRANCH”]=“master” matches devbranch=“master” (if tag is empty)

324│ - :heavy_check_mark: ENV[“DOCUMENTER_KEY”] exists

325│ - :heavy_check_mark: ENV[“TRAVIS_EVENT_TYPE”]=“push” is not “cron”

326└ Deploying: :heavy_check_mark:

327Initialized empty Git repository in /tmp/tmpKoUL0Z/.git/

328Warning: Permanently added the RSA host key for IP address ‘140.82.114.3’ to the list of known hosts.

329ERROR: Repository not found.

330fatal: Could not read from remote repository.

331

332Please make sure you have the correct access rights

333and the repository exists.

334┌ Error: Git failed to fetch git@github.com:Marco-Congedo/FourierAnalysis.jl.git

335│ This can be caused by a DOCUMENTER_KEY variable that is not correctly set up.

336│ Make sure that the environment variable is properly set up as a Base64-encoded string

337│ of the SSH private key. You may need to re-generate the keys with DocumenterTools.

338└ @ Documenter ~/.julia/packages/Documenter/3fOeD/src/Documenter.jl:692

339ERROR: LoadError: failed process: Process(git fetch upstream, ProcessExited(128)) [128]

340Stacktrace:

341 [1] error(::String, ::Base.Process, ::String, ::Int64, ::String) at ./error.jl:42

342 [2] pipeline_error at ./process.jl:705 [inlined]

343 [3] #run#505(::Bool, ::Function, ::Cmd) at ./process.jl:663

344 [4] run at ./process.jl:661 [inlined]

345 [5] (::getfield(Documenter, Symbol("##19#24")){String,String,SubString{String},String,Array{Any,1},Bool,String,String})() at /home/travis/.julia/packages/Documenter/3fOeD/src/Documenter.jl:690

346 [6] cd(::getfield(Documenter, Symbol("##19#24")){String,String,SubString{String},String,Array{Any,1},Bool,String,String}, ::String) at ./file.jl:96

347 [7] #18 at /home/travis/.julia/packages/Documenter/3fOeD/src/Documenter.jl:681 [inlined]

348 [8] withfile(::getfield(Documenter, Symbol("##18#23")){String,String,SubString{String},String,Array{Any,1},Bool,String,String,String}, ::String, ::String) at /home/travis/.julia/packages/Documenter/3fOeD/src/Documenter.jl:806

349 [9] #git_push#17(::String, ::String, ::String, ::String, ::String, ::SubString{String}, ::String, ::Array{Any,1}, ::Bool, ::typeof(Documenter.git_push), ::String, ::String, ::String) at /home/travis/.julia/packages/Documenter/3fOeD/src/Documenter.jl:672

350 [10] #git_push at ./none:0 [inlined]

351 [11] #12 at /home/travis/.julia/packages/Documenter/3fOeD/src/Documenter.jl:620 [inlined]

352 [12] mktempdir(::getfield(Documenter, Symbol("##12#16")){String,String,String,String,String,String,Array{Any,1},Bool,String,String,SubString{String}}, ::String) at ./file.jl:581

353 [13] mktempdir at ./file.jl:579 [inlined]

354 [14] (::getfield(Documenter, Symbol("##11#15")){String,String,String,String,String,Nothing,String,Array{Any,1},Bool,String,String,SubString{String}})() at /home/travis/.julia/packages/Documenter/3fOeD/src/Documenter.jl:619

355 [15] cd(::getfield(Documenter, Symbol("##11#15")){String,String,String,String,String,Nothing,String,Array{Any,1},Bool,String,String,SubString{String}}, ::String) at ./file.jl:96

356 [16] #deploydocs#9(::String, ::String, ::String, ::String, ::String, ::Nothing, ::Nothing, ::Nothing, ::Nothing, ::Nothing, ::String, ::String, ::Array{Any,1}, ::Bool, ::typeof(deploydocs)) at /home/travis/.julia/packages/Documenter/3fOeD/src/Documenter.jl:610

357 [17] (::getfield(Documenter, Symbol("#kw##deploydocs")))(::NamedTuple{(:repo,),Tuple{String}}, ::typeof(deploydocs)) at ./none:0

358 [18] top-level scope at none:0

359 [19] include at ./boot.jl:317 [inlined]

360 [20] include_relative(::Module, ::String) at ./loading.jl:1044

361 [21] include(::Module, ::String) at ./sysimg.jl:29

362 [22] exec_options(::Base.JLOptions) at ./client.jl:266

363 [23] _start() at ./client.jl:425

364in expression starting at /home/travis/build/Marco-Congedo/FourierAnalysis/docs/make.jl:34

365The command “julia --project=docs/ docs/make.jl” exited with 1.

366

367Skipping the after_success step, as specified in the configuration.

368

369Done. Your build exited with 1.

P.S. If I try to run genkeys instead, i have the error below. I have no idea if the two are linked:

julia> Travis.genkeys(user="Marco-Congedo", repo="git@github.com:Marco-Congedo/FourierAnalysis.jl.git")

ERROR: IOError: could not spawn `which which`: no such file or directory (ENOENT)Stacktrace: [1] _spawn_primitive(::String, ::Cmd, ::Array{Any,1}) at .\process.jl:400 [2] setup_stdios(::getfield(Base, Symbol("##505#506")){Cmd}, ::Array{Any,1}) at .\process.jl:413
 [3] success(::Cmd) at .\process.jl:412        
 [4] #genkeys#1(::String, ::String, ::Function) at C:\Users\congedom\.julia\packages\DocumenterTools\Ihxuk\src\Travis.jl:61
 [5] (::getfield(DocumenterTools.Travis, Symbol("#kw##genkeys")))(::NamedTuple{(:user, :repo),Tuple{String,String}}, ::typeof(DocumenterTools.Travis.genkeys)) at .\none:0
 [6] top-level scope at none:0

Ops, the problem was that i inadvertedly named the repository in GitHub ‘FourierAnalysis’ instead of ‘FourierAnalysis.jl’. Now it works.

1 Like