Struggling to access packages with new Julia install

First, apologies, and a request for patience, my techie skills comprise small islands of knowledge in a sea of empty space.

My problem is that I am trying to get Julia running on my laptop. I have been using Anaconda for Python which kept everything very simple and easy, when I needed packages, they were just there, no problems. I’m now keen to switch to Julia. The Anaconda install lets me access Julia, from Jupyter and VScode, but when I try to access any packages I get an error. The same packages are completely accessible from Python.
I have tried to create an environment for Julia, but I’m starting from a position of woeful ignorance, I haven’t needed to think about any of this before, and I don’t have any real understanding of what I’m trying to do (or indeed, what an environment actually is). My techie skills are an unhelpful mix of small islands of knowledge in a sea of emptiness
Can anyone help guide me safely through all this so I can experience the joy of actually using julia without having to do a full computer science course first! :slight_smile:

Not sure what you need to know, here’s everything I can think of as a start point,

The machine I’m using has Windows 10 Pro for workstations OS

In Jupyter and in VS code I can run julia but can’t access any packages, same packages are accessible in both jupyter and VScode if I’m running a python script, see screen shots below.

I know I’m being an idiot! Really hoping for help though!

Hi! Welcome to Julia!

It seems to me that you are trying to use a package called Bokeh that exists for Python. Julia is a different programming language than python, and most of the packages that exist for python do not exist for julia exactly the same. In most cases you will be able to find packages for julia that have the same goals as those of python, but they won’t have necessarily the same name as those in python.

That said, after a quick look around I found a Bokeh.jl package for julia that existed once but doesn’t exist anymore, maybe you were looking at a very old tutorial? Were you instructed to install the Bokeh package for julia at some course of tutorial?

Have you tried installing other julia packages and failed? (for example, what if you install the package GR ?)


Hi, thank you for taking time to respond. Yes I have the same problem with all the packages I have tried, including pandas and numpy, which I recall using on the Julia course I did. Are there different versions of these which I need to find and install separately from the python versions?

You have a fundamental misunderstanding about how Julia works - it is a completely seperate programming language from Python, and as such there are no “different versions” of Python packages that you install in Julia, there are just completely different packages in Julia that might do the same things as the packages you’re using in Python.

Some suggestions to get you started:

  • numpy: no need to add any packages in Julia, as arrays etc. are built into the language. For some things you might want to use LinearAlgebra, which is a standard library in Julia
  • pandas: there are lots of packages for working with tabular data in Julia, although the most popular and closest to pandas is probably DataFrames.jl (albeit with a slightly more R- than Python-inspired syntax it’s fair to say)
  • matplotlib: as your trhead is about a plotting package, for plotting there are again various packages in Julia, the most widely used is probably Plots.jl with a syntax not too far from matplotlib; there is also PyPlot.jl which directly wraps matplotlib, plus various wrappers for other libraries (as you found out the Bokeh one might be unmaintained, but there’s VegaLite, GNUPlot, PGFPlots etc)

Finally, if there’s a Python package you can’t live without consider using PyCall, which allows you to call Python packages from Julia. Note that this does not mean “installing” a Python package in Julia, you would be running a separate Python instance which has the package installed, which is then being called from Julia.


Pandas and numpy are python packages, not julia packages, you won’t be able to use them .

Julia doesn’t have an equivalent for numpy because it doesn’t need it (the functionality is built in the language).

For pandas I am not an expert but maybe DataFrames can be useful. Be aware, however, that the syntax will be different as well (python scripts will not work in julia).

Maybe in your course you were using the PyCall package to use python packages in julia?

Can you share a notebook or a code example from your course?

Once again, I must ask if you have problems installing Julia packages, for example GR.

OK, thank you both for your restrained responses to my idiotic questions. Your replies prompted me to find and open the examples from the julia Scientific Programming Course I did, because I was convinced that’s where I’d met pandas and numpy. Of course, no I didn’t. I have managed to blur my memory of the course with my subsequent learning and use of python.
I am an idiot. Running Pkg.add(“DataFrames”) in jupyter seems to work fine.
Thank you afgain for being so kind and not stack overflowy about my dumbness.
I will do better going forward, once I get over the shame and embarassment! :blush:


No need to beat yourself up over it - glad it works for you now!

1 Like

@PennyL Everyone here is very friendly. Please continue to ask questions. I Can assure you that you will get a useful and nice reply every time.

1 Like