Stack plot-pane and terminal

Currently, my layout looks like this:

I would LOVE for it to look like this to utilize the space better:

I could not find out how - does anyone know if it is possible? If not, this is a feature request :slight_smile:

4 Likes

Apparently that is not possible. Interesting how priorities differ between people. I don’t use VS just because of that.

2 Likes

It is technically possible, but we’d need to change our plot pane implementation and it would be really hard (or impossible) to make that configurable, I think.

1 Like

What do you use instead?

Well that sucks… I mean, both the terminal and the plot-pane are currently only using half the height they are allocated, and stacking them would just be perfect. It is really annoying, and I don’t really see the big problem fundamentally. But I don’t know what goes on in the belly of VSCode… I would really love this feature tho.

If hard to make configurable, I would argue that this is a MUCH better default for most users.

Old style vim+terminal+plot pane wherever I want them.

FWIW, you can also just disable the plot pane in VSCode :slight_smile:

1 Like

That would make everything a pop-out, standalone window, right? Because I generally dont really want that - it can be quite messy IMO, with multiple plots.
i can currently send the code to the terminal as opposed to inline-evaluation to get a pop-out anyways, if needed

Agreed, pretty annoying. VSCode panel can’t be split with an editor, only with another panel. Julia extension has to change plot pane to a panel instead of an editor window that it is currently. Or REPL has to become an editor window instead of a terminal. Both are pretty hard I would imagine.

Otherwise UnicodePlots.jl is an option, or use TerminalExtensions.jl to see images inline with iTerm.

What do you use to send code from VSCode to an external terminal?

The way I “send the code to the terminal” is with the VSCode-comman below:

It is to the internal terminal. But when using this command, as opposed to


, the effect seemed to be as if I created a GLMakie-plot in a standalone terminal - I got an interactive pop-out window. For reference, the GLMakie-plots are not interactive in the plot pane, and one should use WGLMakie for interactivity in the plot pane.