"Run file in New Process" in VS Code runs forever

I have a file with a simple single-line code println("Hello") .

When I press “Julia: Run File in New Process” in VS Code on Windows 10, it is trying to start the process forever. It shows the little palette with the red square and the green circular arrow, but apart from this, does nothing. The same happens if I press Ctrl+F5. If, however, I try to “Debug File in New Process” or try to execute the active file in REPL, everything works fine.

A week ago everything worked well. Could someone help me to resolve the problem? I have no idea how to approach this issue.


Things I tried that didn’t help:

  • Restarting Julia Language Server
  • Rebooting computer
  • Uninstalling Julia from VS Code extensions and installing it again
  • Reinstalling Julia on my computer
  • Reinstalling VS Code on my computer
  • Creating a new empty project with the newest version of Julia (1.7.3) → same behavior

Can you do Ctrl-shift-P and then select “Julia: Restart Language Server”? Does that help?

Otherwise, does this persist after you reboot your computer?

Yes, the issue persists after restarting the language server and after rebooting the computer. I have also tried doing it in a different workspace. Didn’t help.

One additional piece of information: recently my laptop overheated and restarted by itself while VS Code was open. I don’t know if this is relevant to the issue.

This should be fixed by Fix "Run in new REPL" by pfitzseb · Pull Request #2966 · julia-vscode/julia-vscode · GitHub, so stay tuned for the next release.