REPL errors when started from VSCode (connected to a server via remote SSH)

Hi there julians

I have VSCode on my laptop, which then connects to a server via Remote SSH extension. Julia is installed on the server. Untill yesterday, everything worked fined. However, since then I can’t start Julia REPL anymore. I always get this error:

ERROR: LoadError: IOError: connect: name too long (ENAMETOOLONG)
 [1] wait_connected(x::Base.PipeEndpoint)
   @ Sockets /opt/julia-1.8.5/share/julia/stdlib/v1.8/Sockets/src/Sockets.jl:529
 [2] connect
   @ /opt/julia-1.8.5/share/julia/stdlib/v1.8/Sockets/src/Sockets.jl:564 [inlined]
 [3] connect
   @ /opt/julia-1.8.5/share/julia/stdlib/v1.8/Sockets/src/PipeServer.jl:103 [inlined]
 [4] serve(args::String; is_dev::Bool, crashreporting_pipename::String)
   @ VSCodeServer ~/.vscode-server/extensions/julialang.language-julia-1.52.2/scripts/packages/VSCodeServer/src/VSCodeServer.jl:110
 [5] top-level scope
   @ ~/.vscode-server/extensions/julialang.language-julia-1.52.2/scripts/terminalserver/terminalserver.jl:39
in expression starting at /home/cmoraru/.vscode-server/extensions/julialang.language-julia-1.52.2/scripts/terminalserver/terminalserver.jl:14

I’ve tried a couple of things: reinstall julia, reinstall julia extension. But REPL does not work.

On the other hand side, I can start julia in two different ways:

  • from the VSCode terminal I can use “julia” command and I get the julia prompt
  • from a julia code file, when I press “Julia: Run File in New process”

What it does not work is “Julia: Execute file in REPL”

Any suggestions will be appreciated.
thank you, C

My bad, that’s what happens when you work till late: I had messed up my “.bashrc file yesterday” (some paths in it) and till caused REPL to crash.
So, I guess this post can be deleted (or it could serve to other poor soul who messed the paths in the .bashrc)