REPL disappeared


After doing some maintenance on my computer, I returned to Atom, and the Repl disappeared! I uninstalled and reinstalled Juno and Julia-client to no avail. Here is an image of what I see. Looking at the far left side, all the icons are gone. I cannot work! Any advice? Thanks.

Is Juno still installed? It you press Ctrl-P and type julia, do you get any options?

or just follow our update instructions:

1 Like

Yes, I do not see a REPL. I type cmd-P (I am on a macbook pro), and then Julia. Nothing happens. Before Julia can load, I would expect to see the REPL .

When the documentation states

First, close all the Atom windows.

Does that mean close all tabs, or does that mean quit Atom. Not the same thing. The documentation is ambiguous on that point.

It means “Close all instances of Atom”. So yeah, quit it :slight_smile:

I assumed as much :slight_smile: . I first updated all, and then uninstalled and installed ink and julia-client. Nothing worked. I restart Atom, and the same issue. No icons for REPL. Note the following errors:

Failed to load the remote-edit package

The "path" argument must be of type string. Received type undefined
Show Stack Trace
The error was thrown from the remote-edit package. This issue has already been reported.
Failed to load the remote-edit2 package

The "path" argument must be of type string. Received type undefined
Show Stack Trace
The error was thrown from the remote-edit2 package. You can help by creating an issue. Please explain what actions triggered this error.
Incompatible packages detected.

The above packages are incompatible with the current version of Atom and have been deactivated. Juno will not work properly until they are rebuilt.

Earlier this morning, I had drawn the conclusion that I would have to reinstall Atom. What a nightmare if that is true. Also: this problem occurred after a cleanup of my system using the Onyx app, which has never been an issue until just now. Assuming that is the culprit.

Also notice the following message I received when trying to rebuild julia-client:

julia-client 0.12.5
node-pty-prebuilt-multiarch@0.9.0 – The module '/Users/erlebach/.atom/packages/julia-client/node_modules/node-pty-prebuilt-multiarch/build/Release/pty.node' was compiled against a different Node.js version using NODE_MODULE_VERSION 70. This version of Node.js requires NODE_MODULE_VERSION 69. Please try re-compiling or re-installing the module (for instance, using `npm rebuild` or `npm install`).

I have to go to a PREVIOUS version of Node.js? If I do that, then something else could break. What is happening?

Finally, when I try to update Atom via the menu, I get the following message: (note that Atom in my /Applications folder, which should not be read only)

I have had this error too. I went the route of complete uninstall and reinstall. Another approach is to go into the folder where Atom add-ons are stored and forcefully delete all add-ons related to Julia. Then restart Atom and reinstall all add-ons again - then it worked, after restarting a 2nd time.

Kind regards

Yes, when in doubt, delete everything and restart. It goes without saying that when one has 20 or 30 precompiled Julia libraries, this is not something I look forward to. What a waste of time!! I do appreciate your reply. Atom and associated software, including Julia, have a long way to go before they achieve the robustness (or perceived robustness) of Python. But I do like the language (Julia).

Problem solved: I followed your advice. I deleted ink, remote-edit, remote-edit-2, julia-client, which were mentioned in the errors posted above. I then reinstalled them, quit, atom, and relaunched. All icons are back. Precompilation of all my libraries was instantaneous!! What a great feeling! Thank you so much for the approach, @Ahmed_Salih.


Awesome to hear it worked out - maybe it should be put in a FAQ (if not already) to go in and delete directly - seems like it works.

Kind regards