Readlines in Pluto limiting file size

I am trying to read in files with a lot of lines using Pluto. However, readlines seems to be limited to 137k odd lines, where I need 142k lines to be read. If I run the code in a Julia REPL outside of Pluto it sees the whole file, but inside Pluto it is limited. Is this a Pluto thing, or is it possible I am missing something?

filedir = open_dialog("select file")
file = readlines(filedir)

I just created a little example that I tried in both the Julia REPL and in Pluto and both worked. The example is

julia> open("myfile.txt", "w") do io
           for i in 1:200_000
               write(io, "$(rand())\t$(rand())\n")

julia> tmp = readlines("myfile.txt");

julia> length(tmp)

In Pluto I increased the file size to 2 million lines and still no problem.

Hi @Jake, I tried your example in Pluto, and readlines reads all 200,000 lines on my machine as well. My file is text of different length lines. Perhaps that is why I am limited? Or maybe there is something that says EOF?

Is there a way to share *.txt files here? I would love it if someone else could check it out