Re-opening folder in Atom fails


#1

I am working on Windows and had this issue across Julia 0.5.* and 0.6.0. It occurs when I try to reopen a package folder in atom. Atom starts up, but no files, treeview, or julia extension menu items appear. The only way I found around it is to open the project folder from the command line with the --clear-window-state flag.

I suspect something I do with the window layout brings Atom in an invalid or irrecoverable state.

Did anyone else experience this problem? I tried to find a mention among the issues of Juno.jl, Atom.jl and atom-julia-client but could not immediately find something similar.


#2

What do you mean by “reopen”? Does Ctrl-N or similar work in the “broken” Atom window?


#3

By reopen I simply mean I had the same directory open in a previous atom session. Never had the issue with a pristine folder. I understand atom caches some per directory info? This also would explain my workaround solves things.


#4

If you still have the old atom session open, then your issue is the same as Juno on multiple monitors?. If not then that’s some other bug which I at least haven’t seen yet.


#5

As far as I understand I am not in that scenario. Do you have any tips to generate diagnostic output?


#6

How are you starting Atom? atom foldername or from the context menu?


#7

I usually use the recently opened list you get when right clicking an icon pinned to the task bar. But I vaguely remember trying to launch from the command prompt using atom . from within the relevant directory with the same result.

I would experiment so I could give you more accurate information but I do not exactly understand what triggers this issue.


#8

Okay, I just tried on Windows and couldn’t reproduce this with atom ., close Atom completly, atom ..
Would be interesting to now what happens for you with those steps with and without --safe.


#9

Hi again. Sorry for the silence but because I do not understand what triggers the bug I had to wait for it to happen again. Short answer, regardless of whether I include --safe the result is the same: a completely empty atom window.

Within that Window, nothing seems to work anymore: creating new files, opening the settings tab, showing the about… window.

Like mentioned before

atom . --clear-window-state

seems to be the only way out.


#10

I’m also working on windows, and I had experienced wonky Atom behavior time to time when opening a new window. (sometimes empty window appears, but not broken like your case)
But I got around this problem with project-manager packages.
Whenever I want to load some specific project, I just push alt-shift-p and choose a project from there.