Radial_surrogates Installations Error

I am trying to add the Radial basis to my Julia but getting this error. Please help me
MethodError: no method matching RadialBasis(::Array{Float64,1}, ::Array{Float64,1}, ::Int64, ::Int64)
Closest candidates are:
RadialBasis(::Any, ::Any, ::Number, ::Number, ::Function, ::Int64) at C:\Users\Manisha Gowda.julia\packages\Surrogates\dfpEW\src\Radials.jl:25
RadialBasis(::F, ::Int64, ::X, ::Y, ::B, ::C) where {F, X, Y, B, C} at C:\Users\Manisha Gowda.julia\packages\Surrogates\dfpEW\src\Radials.jl:7
RadialBasis(::Any, ::Any, ::Any, ::Function, ::Int64) at C:\Users\Manisha Gowda.julia\packages\Surrogates\dfpEW\src\Radials.jl:40

[1] top-level scope at In[16]:1

Have you tried running the example from the documentation here?


Yeah at the first i have used the same code to run,But I am getting the same error

Are you sure you are on the latest version? You might be using an old version of the package which had a different API? (Indeed looking at the 1.0 documentation it includes the RadialBasis(::Any, ::Any, ::Any, ::Function, ::Int64) signature given in your error message)

I am using the Julia 1.0.5 image
guess this is the latest version.

Sorry I meant version of the Surrogates package, not version of Julia - but this is a good point, Julia 1.0.5 is very much not the latest, the current Julia release is 1.6, and many packages do not support v1.0.5 any longer. You should be using 1.6