Questions about restarting, moving the display of, and stopping output in the REPL in VS Code

I have used the Atom IDE for Julia (JuliaPro/Juno) for a few years, but recently configured a new computer and decided to install the VS Code extension since the Atom version will no longer be updated. I’ve had a few problems with the REPL that I would appreciate help with.

I have no prior VS Code experience, so apologies if I’m missing obvious things there!

  1. The documentation says that Alt+K will stop the kernel, like Ctrl+J+K did in the Atom version. However, I’ve been unable to get this shortcut to have any effect. Am I doing something wrong?
  2. Similarly, is there any equivalent to the Ctrl+C command in the Atom version which stops only the current command being executed?
  3. In Atom, the pane layout would be retained from session to session, including the location of the REPL. In VS Code, it always starts in its location with Powershell in the bottom of the window, and I have to drag it out to my preferred location. Is there a way to retain that location?
  4. Is there a way to stop the automatic REPL output of all commands? I prefer to have only the inline results unless I specifically request output in the REPL. Even ending lines with a semicolon prints a blank line, which gets inconvenient when it pushes something I actually want to see out of view.
1 Like

With all these, few more things wanted to talk about here, regarding hovering on objects/in-line results in VS Code Julia Extension.

— When we hover on any inline result with a data-structure (e.g., result after we run the line with this array A = [10, 12, 14, 16]) it expands to show the array. But when we move the mouse-cursor away, the result disappears. Many times, need to keep that expanded in-line result open and start writing the next line of code. How is that possible?

— When we hover in the IDE for any reason, on any function/attribute the mouse-cursor we hover by, it starts showing documentations of those functions even if we don’t want so. Sometimes it becomes messy, difficult to focus. How can we stop it showing documentations when we hover on something unintentionally in the IDE?

It would be great help if someone can please provide solutions in these issues?

Thank you.

I think it stops the kernel with key binding Alt+j+k.
In VS Code, you can please go to
Settings > Keyboard Shortcuts
to check available/possible keybindings. Or, simply press Ctrl+k+s.