Problems using JuliaMono in VsCode

I’ve got in trouble after adding the JuliaMono fonts along the description given in


The result within the terminal window looks like (all text are in monospace):
How can I get rid of the monospace and back to the variable-width font?
My JSON settings are:

Moreover how can I change the Julia prompt from „julia>“ to e.g. „v1.5> (v$version) or „>“ within VsCode?

Pretty sure you need to use JuliaMono instead of JuliaMono-Regular.

1 Like

After changing “terminal.integrated.fontFamily”: “JuliaMono-Regular” to “terminal.integrated.fontFamily”: “JuliaMono” the appearance is still the same
Nevertheless, thank you for your.quick response.

Are you sure you properly installed JuliaMono? I have

    "editor.fontFamily": "'JuliaMono', 'Source Code Pro', Consolas, 'Courier New', monospace",

in the settings on my Windows machine and that works fine for both the editor and the terminal.

1 Like

Again thank you for prompt suggestion. I made a copy from your setting and it works!
Do you an idea to change the standard julia prompt:“julia>” to “>”?

sorry for the mistyping

What is that entered into? I thought I downloaded all the fonts, but I don’t think I have JuliaMono

You can use OhMyREPL.jl for that.

Just open the settings and search for “editor font”.

1 Like

After running in vscode:

using OhMyREPL
OhMyREPL.output_prompt!(">", :red)

the prompt is still julia>

That is the output prompt:

julia> OhMyREPL.output_prompt!(">", :red)

julia> 1+1
>2

julia> "hello"
>"hello"
1 Like

I’m also pretty sure there’s a bug where we print the wrong prompt under certain circumstances. Should be fixed in the next release though…

I was wrong! I swapped input and output
OhMyREPL.input_prompt!(">", :green) do the job

Thank you for your reply

1 Like

I’m not sure where that is, I found “font family”