Problem adding SPICE dependency into a custom module

Hi all,

I’m writing a custom module “MyModule” in my local users/calum/.julia/dev.

In MyModule i have a few dependencies that I added manually to the project.toml:

[deps]
LinearAlgebra = "37e2e46d-f89d-539d-b4ee-838fcccc9c8e"
SPICE = "5bab7191-041a-5c2e-a744-024b9c3a5062"
Dates = "ade2ca70-3891-5945-98fb-dc099432e06a"
DataFrames = "a93c6f00-e57d-5684-b7b6-d8193f3e46c0"
ReferenceFrameRotations = "74f56ac7-18b3-5285-802d-d4bd4f104033"

When I run a code that uses functions defined in MyModule I get a warning just for the SPICE package.

┌ Warning: Package MyModule does not have SPICE in its dependencies:
│ - If you have MyModule checked out for development and have
│   added SPICE as a dependency but haven't updated your primary
│   environment's manifest file, try `Pkg.resolve()`.
│ - Otherwise you may need to report an issue with MyModule
└ Loading SPICE into MyModule from project dependency, future warnings for MyModule are suppressed.

If I remember correctly, SPICE is not included in the Julia package manger yet (It was installed originally to my Julia environment by cloning the http link form the git repository), so I thought this warning might have something to do with this.

Any ideas how to add SPICE as a dependent package to MyPackage?

Thanks!

I think what you’re saying is that SPICE isn’t yet registered as a Julia package (meaning it doesn’t have an entry on the general registry such that Pkg knows what you mean if you just type add SPICE).

I’m not an expert in unregistered packages, and when I tried to do something like this I gave up and squashed everything into a single unregistered package that I dev'd and called via using in a script. But the following might help:

https://discourse.julialang.org/t/pkg-workflow-for-unregistered-packages/17385