Problem with MKL_jll in Mac OS

Hi there!

I am using the book pro-M2,
and now using VSC to implement Julia codes,

I just wrote several using the package and ran the program as below:

using LinearAlgebra
using JuMP
using Mosek
using MosekTools
using ControlSystems

But there is this warning (while I have not added any code yet!) I also restart Julia but still same warning:

┌ Warning: MKL_jll is not available/installed.
└ @ MKL ~/.julia/packages/MKL/kCNzy/src/MKL.jl:39

I searched and it seems MKL is not available for Mac, what should I do?

update: version of my MKL: 0.6.3, and it seems this warning is come with ControlSystem Package

Hi @Sharara as I often say on here “Good enough for Jazz”. In this case think of learning to play jazz on the piano. You have to do a lot of exercises and scales before your masterclass performance.
I ask the audience - can we suggest some exercises @Sharara can run?

ps. What does using Pkg; Pkg.status() return?

1 Like

Dear johnh

Thanks for your valuable advice and reply,
It is 2 up to 2 months since I moved to Julia (from MATLAB),
I started with Julia’s Youtube and followed all possible and related videos,
Then I tried to implement package examples one by one,

Then I started to implement my code, But

some errors or warnings are unknown to me and via search, I could not find reasonable answers,
for example, this topic, the previous week, for the same program, there was not such a warning,
But today it is coming and I could not solve it, I also tried to restart Julia and my system.

here is the output for status:

julia> using Pkg

julia> Pkg.status()
Status `~/.julia/environments/v1.10/Project.toml`
  [731a2950] AutomationLabsModelPredictiveControl v0.1.4
  [1e616198] COSMO v0.8.8
  [a076750e] CPLEX v1.0.3
  [49dc2e85] Calculus v0.5.1
  [a6e380b2] ControlSystems v1.10.1
  [f65535da] Convex v0.15.4
  [e2685f51] ECOS v1.1.2
  [60bf3e95] GLPK v1.1.3
  [2e9cd046] Gurobi v1.2.2
  [7073ff75] IJulia v1.24.2
  [42fd0dbc] IterativeSolvers v0.9.4
  [4076af6c] JuMP v1.20.0
  [98e50ef6] JuliaFormatter v1.0.54
  [9907b50f] LimitOfDetection v0.1.1
  [f5a24dde] LimitedLDLFactorizations v0.5.1
  [5c8ed15e] LinearOperators v2.7.0
  [33e6dc65] MKL v0.6.3
  [b8f27783] MathOptInterface v1.27.0
  [99c1a7ee] MatrixEquations v2.4.2
  [f28f55f0] Memento v1.4.1
  [93a108e7] ModelMiner v0.1.0
  [6405355b] Mosek v10.1.4
  [1ec41992] MosekTools v0.15.1
  [01bcebdf] Nonconvex v2.1.3
  [ab2f91bb] OSQP v0.8.0
  [429524aa] Optim v1.9.3
  [14b8a8f1] PkgTemplates v0.7.48
  [91a5bcdd] Plots v1.40.2
  [65e78d25] ProxSDP v1.8.3
  [c946c3f1] SCS v2.0.0
  [770da0de] UpdateJulia v0.4.4
  [856f044c] MKL_jll v2024.0.0+0
  [c04a2911] nlminb_jll v0.1.1+0
  [37e2e46d] LinearAlgebra

@Sharara it looks like you are doing exactly what I did when new to Julia - installing lots of packages in global scope. I find that the packages then ‘trip over’ each other.

I would advise that you create separate projects for each model you want to work with or each new piece of work you want to work on

Can anyone reccomend a good writeup on Julia project workflows?

Also please remove UpdateJulia and I would remove the MKL package also

1 Like


I could create a special project and as you mentioned it seems much better, thank you!

one challenge that I faced while I was using Julia, was understanding the Errors…

I could not understand it well…

Now I have implemented my LMI optimization algorithm, but I received this error:

MethodError: no method matching iterate(::Model)

Closest candidates are:
   @ LibGit2 ~/.julia/juliaup/
  iterate(!Matched::LibGit2.GitBranchIter, !Matched::Any)
   @ LibGit2 ~/.julia/juliaup/
  iterate(!Matched::Pkg.Types.Manifest, !Matched::Int64)
   @ Pkg ~/.julia/juliaup/

 [1] top-level scope
   @ /Volumes/University/Codes/Julia/SOF.ipynb:56

any help will save me …