Issues installing IJulia

Hi,
unfortunately I’m not the most experienced Linux user and when I try to Pkg.build(“IJulia”) I always get the following error msg

INFO: Building Conda
INFO: Building MbedTLS
INFO: Building ZMQ
INFO: Building IJulia
Warning: `/nethome/harnold8/.julia/v0.6/Conda/deps/usr/bin/jupyter --version` returned an unrecognized version number jupyter core     : 4.6.1
jupyter-notebook : 6.0.2
qtconsole        : 4.6.0
ipython          : 7.11.1
ipykernel        : 5.1.3
jupyter client   : 5.3.4
jupyter lab      : not installed
nbconvert        : 5.6.1
ipywidgets       : 7.5.1
nbformat         : 5.0.3
traitlets        : 4.3.3
Info: /nethome/harnold8/.julia/v0.6/Conda/deps/usr/bin/jupyter was too old: got 0.0.0, required ≥ 3.0
Info: Installing Jupyter via the Conda package.
Info: Running `conda install -y jupyter` in root environment
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: / 
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.
failed                                                                                                                                                                                                             
                                                                                                                                                                                                                   
UnsatisfiableError: The following specifications were found                                                                                                                                                        
to be incompatible with the existing python installation in your environment:

Specifications:

  - jupyter -> python[version='>=2.7,<2.8.0a0|>=3.5,<3.6.0a0|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']

Your python: python=3.8

If python is on the left-most side of the chain, that's the version you've asked for.
When python appears to the right, that indicates that the thing on the left is somehow
not available for the python version you are constrained to. Note that conda will not
change your python version to a different minor version unless you explicitly specify
that.

The following specifications were found to be incompatible with each other:



Package ipython conflicts for:
jupyter -> ipykernel -> ipython[version='>=4.0|>=4.0.0|>=5.0']
Package certifi conflicts for:
jupyter -> ipykernel -> ipython[version='>=4.0'] -> jedi[version='>=0.10'] -> numpydoc -> sphinx -> requests[version='>=2.0.0'] -> certifi[version='>=2017.4.17']
jupyter -> jupyter_console -> pygments -> setuptools -> certifi[version='>=2016.09|>=2016.9.26']
jupyter -> ipykernel -> tornado[version='>=4.0'] -> certifi
python=3.8 -> pip -> setuptools -> certifi[version='>=2016.09|>=2016.9.26']
Package wheel conflicts for:
python=3.8 -> pip -> wheel
jupyter -> python[version='>=2.7,<2.8.0a0'] -> pip -> wheel
Package setuptools conflicts for:
jupyter -> jupyter_console -> pygments -> setuptools
python=3.8 -> pip -> setuptools
Package python-dateutil conflicts for:
jupyter -> ipykernel -> jupyter_client -> python-dateutil[version='>=2.1']
Package ca-certificates conflicts for:
python=3.8 -> openssl[version='>=1.1.1d,<1.1.2a'] -> ca-certificates
jupyter -> python[version='>=2.7,<2.8.0a0'] -> ca-certificates
Package pip conflicts for:
python=3.8 -> pip
jupyter -> python[version='>=2.7,<2.8.0a0'] -> pip

=================================================================================================[ ERROR: IJulia ]=================================================================================================

LoadError: failed process: Process(setenv(`/nethome/harnold8/.conda/envs/conda_jl/bin/conda install -y jupyter`,String["PATH=/usr/local/packages/miniconda3/bin:/usr/local/packages/miniconda3/bin:/usr/local/packages/miniconda3/bin:/usr/local/packages/miniconda3/bin:/usr/local/packages/miniconda3/bin:/usr/local/packages/miniconda3/bin:/usr/local/packages/miniconda3/bin:/usr/local/packages/miniconda3/bin:/usr/lib64/qt-3.3/bin:/nethome/harnold8/perl5/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:/nethome/harnold8/.local/bin:/nethome/harnold8/bin", "QTDIR=/usr/lib64/qt-3.3", "PERL_MM_OPT=INSTALL_BASE=/nethome/harnold8/perl5", "DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-heXaYXpsli,guid=9dbf67b0dd4297c744095d1b5e1352bf", "MODULEPATH=/usr/share/Modules/modulefiles:/etc/modulefiles", "PERL5LIB=/nethome/harnold8/perl5/lib/perl5:", "XDG_SESSION_DESKTOP=gnome-classic", "SSH_AGENT_PID=10081", "XDG_SESSION_TYPE=x11", "USER=harnold8", "QT_IM_MODULE=xim", "USERNAME=harnold8", "GNOME_SHELL_SESSION_MODE=classic", "GDMSESSION=gnome-classic", "MATHEMATICA_HOME=/usr/local/packages/Wolfram/Mathematica/11.2", "XDG_DATA_DIRS=/nethome/harnold8/.local/share/flatpak/exports/share/:/var/lib/flatpak/exports/share/:/usr/local/share/:/usr/share/", "LESSOPEN=||/usr/bin/lesspipe.sh %s", "SHELL=/bin/bash", "QT_PLUGIN_PATH=/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins", "XDG_SEAT=seat0", "XAUTHORITY=/run/gdm/auth-for-harnold8-3uU2Qz/database", "XDG_MENU_PREFIX=gnome-", "CONDARC=/nethome/harnold8/.conda/envs/conda_jl/condarc-julia.yml", "SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/9889,unix/unix:/tmp/.ICE-unix/9889", "QTLIB=/usr/lib64/qt-3.3/lib", "XMODIFIERS=@im=none", "TERM=xterm-256color", "HOME=/nethome/harnold8", "HOSTNAME=eas-est-323503.eas.gatech.edu", "QTINC=/usr/lib64/qt-3.3/include", "VTE_VERSION=5202", "COLORTERM=truecolor", "PYTHONIOENCODING=UTF-8", "HISTSIZE=1000", "PERL_LOCAL_LIB_ROOT=:/nethome/harnold8/perl5", "XDG_CURRENT_DESKTOP=GNOME-Classic:GNOME", "LANG=en_US.UTF-8", "SHLVL=2", "LOADEDMODULES=", "IMSETTINGS_INTEGRATE_DESKTOP=yes", "GNOME_DESKTOP_SESSION_ID=this-is-deprecated", "LOGNAME=harnold8", "OLDPWD=/usr/local/packages/julia/d386e40c17", "SSH_AUTH_SOCK=/run/user/908581/keyring/ssh", "DESKTOP_SESSION=gnome-classic", "GDM_LANG=en_US.UTF-8", "IMSETTINGS_MODULE=none", "XDG_RUNTIME_DIR=/run/user/908581", "_=/usr/local/bin/julia", "QT_GRAPHICSSYSTEM_CHECKED=1", "GNOME_TERMINAL_SCREEN=/org/gnome/Terminal/screen/d4b04ad0_9e52_41ec_abc0_926decff4097", "GNOME_TERMINAL_SERVICE=:1.121", "PWD=/nethome/harnold8", "KRB5CCNAME=FILE:/tmp/krb5cc_908581_sBQoZH", "MODULESHOME=/usr/share/Modules", "DISPLAY=:0", "BASH_FUNC_module()=() {  eval `/usr/bin/modulecmd bash \$*`\n}", "OPENBLAS_NUM_THREADS=8", "LD_PRELOAD=/nethome/harnold8/.julia/v0.6/Conda/deps/usr/lib/libz.so", "HISTCONTROL=ignoredups", "MAIL=/var/spool/mail/harnold8", "XDG_VTNR=1", "CONDA_PREFIX=/nethome/harnold8/.conda/envs/conda_jl", "XDG_SESSION_ID=3", "KDEDIRS=/usr", "PERL_MB_OPT=--install_base /nethome/harnold8/perl5", "WINDOWPATH=1", "LS_COLORS=rs=0:di=38;5;27:ln=38;5;51:mh=44;38;5;15:pi=40;38;5;11:so=38;5;13:do=38;5;5:bd=48;5;232;38;5;11:cd=48;5;232;38;5;3:or=48;5;232;38;5;9:mi=05;48;5;232;38;5;15:su=48;5;196;38;5;15:sg=48;5;11;38;5;16:ca=48;5;196;38;5;226:tw=48;5;10;38;5;16:ow=48;5;10;38;5;21:st=48;5;21;38;5;15:ex=38;5;34:*.tar=38;5;9:*.tgz=38;5;9:*.arc=38;5;9:*.arj=38;5;9:*.taz=38;5;9:*.lha=38;5;9:*.lz4=38;5;9:*.lzh=38;5;9:*.lzma=38;5;9:*.tlz=38;5;9:*.txz=38;5;9:*.tzo=38;5;9:*.t7z=38;5;9:*.zip=38;5;9:*.z=38;5;9:*.Z=38;5;9:*.dz=38;5;9:*.gz=38;5;9:*.lrz=38;5;9:*.lz=38;5;9:*.lzo=38;5;9:*.xz=38;5;9:*.bz2=38;5;9:*.bz=38;5;9:*.tbz=38;5;9:*.tbz2=38;5;9:*.tz=38;5;9:*.deb=38;5;9:*.rpm=38;5;9:*.jar=38;5;9:*.war=38;5;9:*.ear=38;5;9:*.sar=38;5;9:*.rar=38;5;9:*.alz=38;5;9:*.ace=38;5;9:*.zoo=38;5;9:*.cpio=38;5;9:*.7z=38;5;9:*.rz=38;5;9:*.cab=38;5;9:*.jpg=38;5;13:*.jpeg=38;5;13:*.gif=38;5;13:*.bmp=38;5;13:*.pbm=38;5;13:*.pgm=38;5;13:*.ppm=38;5;13:*.tga=38;5;13:*.xbm=38;5;13:*.xpm=38;5;13:*.tif=38;5;13:*.tiff=38;5;13:*.png=38;5;13:*.svg=38;5;13:*.svgz=38;5;13:*.mng=38;5;13:*.pcx=38;5;13:*.mov=38;5;13:*.mpg=38;5;13:*.mpeg=38;5;13:*.m2v=38;5;13:*.mkv=38;5;13:*.webm=38;5;13:*.ogm=38;5;13:*.mp4=38;5;13:*.m4v=38;5;13:*.mp4v=38;5;13:*.vob=38;5;13:*.qt=38;5;13:*.nuv=38;5;13:*.wmv=38;5;13:*.asf=38;5;13:*.rm=38;5;13:*.rmvb=38;5;13:*.flc=38;5;13:*.avi=38;5;13:*.fli=38;5;13:*.flv=38;5;13:*.gl=38;5;13:*.dl=38;5;13:*.xcf=38;5;13:*.xwd=38;5;13:*.yuv=38;5;13:*.cgm=38;5;13:*.emf=38;5;13:*.axv=38;5;13:*.anx=38;5;13:*.ogv=38;5;13:*.ogx=38;5;13:*.aac=38;5;45:*.au=38;5;45:*.flac=38;5;45:*.mid=38;5;45:*.midi=38;5;45:*.mka=38;5;45:*.mp3=38;5;45:*.mpc=38;5;45:*.ogg=38;5;45:*.ra=38;5;45:*.wav=38;5;45:*.axa=38;5;45:*.oga=38;5;45:*.spx=38;5;45:*.xspf=38;5;45:", "OPENBLAS_MAIN_FREE=1"]), ProcessExited(1)) [1]
while loading /home/harnold8/.julia/v0.6/IJulia/deps/build.jl, in expression starting on line 125

Help please :D! I don’t know why my python version shows up to be 3.8, when I’m using most often 2.7 on my machine.

If you want to use a python version that is already present on your computer, you specify the path to the python executable, see here. Otherwise, you could just add ENV["PYTHON"] = "" to your julia startup file located in ~/.julia/config/startup.jl and Conda will download for you python 3 and the other necessary packages. (These instructions are only valid for Julia >= v1.0.)

EDIT: I realize now that you are using a superold version of Julia, v0.6. You should upgrade to v1.3.1.

3 Likes

someone might want to answer on the equivalent StackOverflow question as well: https://stackoverflow.com/questions/59688804/issues-installing-ijulia

@Romero_Azzalini: if you post the same question on StackOverflow, can you please cross-link to it from here?

I’d love to, but my rights are very limited on the computer and the IT guys often have even less clue then I do and take forever to get things done :(. It worked before I updatet some packages

Just download the generic LInux binary from here.
It will just create a folder with the binary inside that you can run directly without “installing” anything.

3 Likes

With the additional advantage that you will get the newest Julia version without waiting for it to be available in the package manager of your OS distribution.

3 Likes

I downloaded the newest version of julia, did set ENV[“PYTHON”]="" but Pkg.build(“PyCall”)
gives me false :frowning:

Edit: But with preloading the miniconda libz.so everything works now :slight_smile:

Can you post the error message?