Precompiling in 0.7

I have some custom modules that I use that worked fine in 0.6.x. At the top of them, I have the command __precompile__(). I’m now seeing the warnings:

┌ Warning: The call to compilecache failed to create a usable precompiled cache file for MyModule [top-level]
│   exception = Required dependency QuadGK [1fd47b50-473d-5c70-9696-f719f8f3bcdc] failed to load from a cache file.
└ @ Base loading.jl:963

What’s that about, and how can I resolve it?

In 0.7/1.0, the default is to precompile packages, so that explicit statement is no longer needed. If you want to keep the package compatible with 0.6.x and precompile there, check for the version at the top and precompile if it’s less than 0.7.

That error is certainly weird, can you try adding QuadGK on its own and after that loading your module?