Pluto This localhost page can’t be found

Hello all,

I recently started using Julia and Pluto notebook. However, I cannot launch Pluto after downloading it. This is what the error looks like:

Everything appears normal on the Julia cmd, but when it automatically goes to the link, it raises error 404.
I’m on Windows 11, this does not work on both Chrome and Edge. I’m using Julia 1.8.5. I also tried reinstalling Julia and Pluto and restarting the computer, but the same error appeared.

Any help would be greatly appreciated!

No clue really, but since it seems like the connection is not going through it might be some firewall? Though a firewall blocking localhost seems a bit odd. Is this a corporate computer, have you checked if you have some proxy settings in your browser that could mess with this?

You could try debugging by seeing if you get a connection using some similar but more basic tools e.g. curl, which I think come by default with windows, as the client and/or a simple server using HTTP.jl as seen here