Plots figure size

I just switched from Juno/Atom to VSCode and my experience has been mostly great. The one issue I have is the plot figure is tiny no matter what size the Julia Plots window is. In Juno, plots automatically scale to the size of the window they are in on generation. Is there any way to do this in VSCode?

1 Like
gr(size = (750, 565)) # use gr as the plot backend

Works for me in VSCode.

1 Like

Thanks. Kinda unfortunate that this can’t be automatic like in Juno (since I like to resize my windows often), but this will have to do.

Anyone know if there has been any progress on this? Or if not, an issue filed somewhere I can watch?

I wonder if it’s related to the long-outstanding https://github.com/microsoft/vscode/issues/10121 which is also unfortunate.

Or is there maybe a workaround that I’m not aware of, e.g. having plot windows open external to VS Code somehow?

Not sure of understanding the meaning of your question: “having plot windows open external to VS Code somehow?”, but unchecking the VSCode setting herein sends plots to an external window:

That’s in fact exactly what I mean… Unfortunately it doesn’t seem to work for me, or at least not with the PlotlyJS backend, which I prefer for its interactivity (and which does work inside of VS Code). But thanks for the reminder that that option is even there!

(Edit: Big Sur 11.2.3, Julia 1.6.0)

1 Like

Plots’ plotlyjs() backend issues the Kaleido error message (with a spelling typo too):

julia> using Plots; plotlyjs()
Plots.PlotlyJSBackend()
julia> # ┌ Warning: Kaledio is not available on this system. Julia will be unable to produce any plots.
julia> # └ @ PlotlyBase C:\Users\jrafa\.julia\packages\PlotlyBase\NxSlF\src\kaleido.jl:58

This issue seems to be under investigation here.

Ok, I’m not seeing the connection to this issue though (or that error message)…?

I just realized that while I have the same problem, the issue does not seem to lay in the resolution, but in the scaling: I can zoom into the plots and they look good, but the scale makes them absolutely tiny…

I discovered that you can use the size=(x,y) parameter to increase the size of the graph. Works well together will the setting that the graphs are opened in a new window

1 Like