Plot problem


#1

I recently upgraded to Julia 0.6 which I use with Atom on a Win 10 desktop system with core I7 processor where I write science/engineering applications. The applications all work fine except for any plotting with PyPlot or Plot where I get the
error msg shown below. I get this error in both Atom and the REPL. I have uninstalled both Julia and Atom and reinstalled and restarted and I still get the same error. The error actually hangs Julia and I have to exit with the task manager.

Any ideas where I might go from here???

Error


#2

Same problem here on Win 7. I deleted the package dir and reinstalled PyPlot alone, no luck.The symptoms are identical on two different machines.

I tried pinning PyPlot to v2.3.1. That helps in that plot commands seem to execute without producing the runtime error, but no output is produced.

First noticed over a week ago.


#3

Clues seam to point to a python issue. Julia in itself uses no MS Visual C libraries. The “Dependency Walker” should be a friend here but I don’t know where start looking. Maybe in python.exe?


#4

I’m afraid I don’t know much about debugging python-julia issues on Windows, and I can’t test this myself. However, one thing you might try is forcing PyCall (and, thus, PyPlot) to use its own self-contained Python version instead of whatever you may have on your system. Can you try running:

using PyCall
PyCall.python

if that outputs a version inside .julia/v0.6/Conda/deps/usr/bin/python then you’re already using a self-contained Python version and this won’t help. But if it shows some other path on your computer, then you can try:

ENV["PYTHON"] = ""
Pkg.build("PyCall")
Pkg.build("PyPlot")

Failing that, if all you want to do is plot things using Plots.jl, you can just switch to a different backend. I like GR.jl:

Pkg.add("GR")
using Plots
gr()
plot([1,2,3])

#5

This question, by a different user, seemed to be resolved today at StackOverflow by setting the ENV and reinstalling and building PyCall, just as you suggest: https://stackoverflow.com/questions/46399480/julia-runtime-error-when-using-pyplot


#6

Thanks, I’ll try that