Error in using PyPlot in Julia


I use Julia for optimization purposes. I use PyPlot for visualization of the results.

I have used Windows and Mac computer so far, and there was no problem at all.

I recently switched to a Windows computer, installed Julia and Atom. When I type “using PyPlot” it gives the following error.

As the error says, I typed“PyCall”), but it gives another error. I can not post the picture of it, but it says that it could not find system-wide Python.

I could not resolve this problem.

There is a similar discussion here in this forum, but it did not help me to figure this out.

Your help will be much appreciated.

Kind regards

I solved this problem. I had two Python installations in my computer. One is individual installation that I did, and the other is Anaconda installation. Individual installation was 32-bit. What I did is to define ENV[“PYTHON”] to Anaconda installation, which is 64-bit. Then, I run“PyCall”), and restated Julia. This solved the problem.

However, now when I run “using PyPlot”, it says that matplotlib does not match with Python installation. I do not have the Windows computer now. I will upload the error when I have that.

Kind regards